aboutsummaryrefslogtreecommitdiffstats
path: root/Mk/bsd.autotools.mk
diff options
context:
space:
mode:
authorade <ade@FreeBSD.org>2005-11-20 06:04:25 +0800
committerade <ade@FreeBSD.org>2005-11-20 06:04:25 +0800
commitc60fd11803d07f12a5044f0e5584e463f5f4fd26 (patch)
treea265d4d2489db44626f1104fc63a78f755bb3733 /Mk/bsd.autotools.mk
parent6bb838eeda464fd142ada134bce378ff2c763d82 (diff)
downloadfreebsd-ports-gnome-c60fd11803d07f12a5044f0e5584e463f5f4fd26.tar.gz
freebsd-ports-gnome-c60fd11803d07f12a5044f0e5584e463f5f4fd26.tar.zst
freebsd-ports-gnome-c60fd11803d07f12a5044f0e5584e463f5f4fd26.zip
Add a pre-everything:: target that will print out appropriate warnings
if a port is still using the old autotools Makefile constructs. For example: *** AUTOTOOLS WARNING for x11/electricsheep This port is using old autotools constructs which wil be disappearing on 1st January 2006 In most cases, this warning can be fixed by removing all the old constructs and replacing them with: USE_AUTOTOOLS= libtool:13 The first line should be easily parseable by portbuild and tinderbox clusters to flag such ports. I'll be doing a few more sweeps of the ports tree to pick up on any such ports over the coming weeks, before turning off the old system and marking the port BROKEN in such cases.
Diffstat (limited to 'Mk/bsd.autotools.mk')
-rw-r--r--Mk/bsd.autotools.mk10
1 files changed, 10 insertions, 0 deletions
diff --git a/Mk/bsd.autotools.mk b/Mk/bsd.autotools.mk
index eed382d3197a..abb0ea113005 100644
--- a/Mk/bsd.autotools.mk
+++ b/Mk/bsd.autotools.mk
@@ -79,6 +79,16 @@ USE_AUTOTOOLS_COMPAT+= libtool:${WANT_LIBTOOL_VER}:env
BROKEN+= "Mix and match of old and new autotools system prohibited"
. else
USE_AUTOTOOLS= ${USE_AUTOTOOLS_COMPAT}
+_AUTOTOOLS_PN= ${.CURDIR:C/${PORTSDIR}\///}
+pre-everything::
+ @${ECHO} "*** AUTOTOOLS WARNING for ${_AUTOTOOLS_PN}"
+ @${ECHO} This port is using old autotools constructs which wil be"
+ @${ECHO} "disappearing on 1st January 2006"
+ @${ECHO} ""
+ @${ECHO} "In most cases, this warning can be fixed by removing"
+ @${ECHO} "all the old constructs and replacing them with:"
+ @${ECHO} " USE_AUTOTOOLS= ${USE_AUTOTOOLS_COMPAT}"
+ @${ECHO} ""
. endif
.endif