aboutsummaryrefslogtreecommitdiffstats
path: root/Mk/bsd.cmake.mk
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2009-01-31 03:25:22 +0800
committermiwi <miwi@FreeBSD.org>2009-01-31 03:25:22 +0800
commite573869349ade071a6f069903fdb54b2cdc918fb (patch)
tree7bf34e9063ceaeb4efe167ad01135a59df3710e6 /Mk/bsd.cmake.mk
parent46e90b128b00383841955fc7b72479211ff02891 (diff)
downloadfreebsd-ports-gnome-e573869349ade071a6f069903fdb54b2cdc918fb.tar.gz
freebsd-ports-gnome-e573869349ade071a6f069903fdb54b2cdc918fb.tar.zst
freebsd-ports-gnome-e573869349ade071a6f069903fdb54b2cdc918fb.zip
- Update to 2.6.2
- Remove CMAKE_BUILD_TYPE [1] CMAKE_BUILD_TYPE only affects compiler FLAGS and linking with specific library versions (debug |optimized | general). In our case external libraries reside in other ports and only install one version (no separate debug/optimized). Also, the ports system provide correct compiler flags (-g and no optimizations when WITH_DEBUG is used). Thus, cmake buildtypes only add extra compiler flags. Ports will be built correctly both by default and for WITH_DEBUG case. - Also, change WRKSRC to CONFIGURE_WRKSRC. (use CONFIGURE_WRKSRC for configure target instead of WRKSRC) PR: 126507 [1] Submitted by: amdmi3@ [1] Tested with: exp-run Thanks to: pav/amdmi3
Diffstat (limited to 'Mk/bsd.cmake.mk')
-rw-r--r--Mk/bsd.cmake.mk15
1 files changed, 6 insertions, 9 deletions
diff --git a/Mk/bsd.cmake.mk b/Mk/bsd.cmake.mk
index d663c5bd67d5..812642a27374 100644
--- a/Mk/bsd.cmake.mk
+++ b/Mk/bsd.cmake.mk
@@ -7,11 +7,9 @@
# Default: ${CONFIGURE_ENV}
# CMAKE_ARGS - Arguments passed to cmake
# Default: see below
-# CMAKE_USE_PTHREAD - Instruct cmake to use pthreads when
+# CMAKE_USE_PTHREAD - Instruct cmake to use pthreads when
# compiling/linking
# Default: not set
-# CMAKE_BUILD_TYPE - Type of build (release, debug)
-# Default: Release
# CMAKE_VERBOSE - Verbose build
# Default: not set
# CMAKE_SOURCE_PATH - Path to sourcedir for cmake
@@ -47,12 +45,11 @@ CMAKE_ARGS+= -DCMAKE_C_COMPILER:STRING="${CC}" \
-DCMAKE_C_FLAGS:STRING="${CFLAGS}" \
-DCMAKE_CXX_FLAGS:STRING="${CXXFLAGS}" \
-DCMAKE_INSTALL_PREFIX:PATH="${CMAKE_INSTALL_PREFIX}" \
- -DCMAKE_BUILD_TYPE:STRING="${CMAKE_BUILD_TYPE}"
+ -DCMAKE_BUILD_TYPE:STRING=""
#
# Default build type and sourcedir
#
-CMAKE_BUILD_TYPE?= Release
CMAKE_SOURCE_PATH?= .
CMAKE_INSTALL_PREFIX?= ${PREFIX}
@@ -69,10 +66,10 @@ CMAKE_ARGS+= -DCMAKE_THREAD_LIBS:STRING="${PTHREAD_LIBS}" \
.endif
#
-# Force DEBUG buildtype if needed
+# Strip binaries
#
-.if defined(CMAKE_DEBUG) || defined(WITH_DEBUG)
-CMAKE_BUILD_TYPE=DEBUG
+.if !defined(WITH_DEBUG)
+CMAKE_ARGS+= -DCMAKE_INSTALL_DO_STRIP:BOOL=ON
.endif
#
@@ -87,6 +84,6 @@ CMAKE_ARGS+= -DCMAKE_VERBOSE_MAKEFILE:BOOL=ON
#
.if !target(do-configure)
do-configure:
- @cd ${WRKSRC}; ${SETENV} ${CMAKE_ENV} ${CMAKE_BIN} ${CMAKE_ARGS} ${CMAKE_SOURCE_PATH}
+ @cd ${CONFIGURE_WRKSRC}; ${SETENV} ${CMAKE_ENV} ${CMAKE_BIN} ${CMAKE_ARGS} ${CMAKE_SOURCE_PATH}
.endif