aboutsummaryrefslogtreecommitdiffstats
path: root/Mk/bsd.database.mk
diff options
context:
space:
mode:
authorlinimon <linimon@FreeBSD.org>2006-07-05 10:18:09 +0800
committerlinimon <linimon@FreeBSD.org>2006-07-05 10:18:09 +0800
commitfb67af18b21e550e6df94b2054e81c4a8ccc06f1 (patch)
tree1b7f634833f20b01eb331dbb7da5f0c0f4e3faa1 /Mk/bsd.database.mk
parentf22bafe5ba52240f804ab7afc5295b8322233d10 (diff)
downloadfreebsd-ports-gnome-fb67af18b21e550e6df94b2054e81c4a8ccc06f1.tar.gz
freebsd-ports-gnome-fb67af18b21e550e6df94b2054e81c4a8ccc06f1.tar.zst
freebsd-ports-gnome-fb67af18b21e550e6df94b2054e81c4a8ccc06f1.zip
* Change all bogus uses of BROKEN to IGNORE. Note: the BROKEN_WITH_*
forms are retained for compatibility but deprecated [1] * Add sha256 to CHECKSUM_ALGORITHMS [2] * Remove some whitespace [2] * Add USE_SCONS and bsd.scons.mk for the Python-based SCons build system [3] * Fix USE_LDCONFIG with non-default PREFIX [4] * Add USE_WX and friends, and bsd.wx.mk, for common code for WxWidgets support [5] * Add 'make missing' to show missing dependencies [6] * Fix DESKTOP_ENTRIES processing on 4.x [7] PR: 92445 [1], 98206 [2], 98731 [3], 99370 [4], 89398 [5], 93601 [6], 98891 [7] Submitted by: linimon [1], edwin [2], alex at foxybanana dot com [3], gerald [4], flz [4], alepulver [5], alex at fafula dot com [6], shaun [7]
Diffstat (limited to 'Mk/bsd.database.mk')
-rw-r--r--Mk/bsd.database.mk36
1 files changed, 22 insertions, 14 deletions
diff --git a/Mk/bsd.database.mk b/Mk/bsd.database.mk
index 7286894b3516..4af9d90033e3 100644
--- a/Mk/bsd.database.mk
+++ b/Mk/bsd.database.mk
@@ -25,7 +25,7 @@ Database_Include_MAINTAINER= ports@FreeBSD.org
# Default: 50.
# WANT_MYSQL_VER
# - Maintainer can set an arbitrary version of MySQL by using it.
-# BROKEN_WITH_MYSQL
+# IGNORE_WITH_MYSQL
# - This variable can be defined if the ports doesn't support
# one or more version of MySQL.
# WITH_MYSQL_VER
@@ -44,7 +44,7 @@ Database_Include_MAINTAINER= ports@FreeBSD.org
# WANT_PGSQL_VER
# - Maintainer can set an arbitrary version of PostgreSQL by
# using it.
-# BROKEN_WITH_PGSQL
+# IGNORE_WITH_PGSQL
# - This variable can be defined if the ports doesn't support
# one or more versions of PostgreSQL.
# PGSQL_VER
@@ -116,13 +116,17 @@ IGNORE= cannot install: MySQL versions mismatch: mysql${_MYSQL_VER}-client is in
# And now we are checking if we can use it
.if defined(MYSQL${MYSQL_VER}_LIBVER)
+# compatability shim
.if defined(BROKEN_WITH_MYSQL)
-. for VER in ${BROKEN_WITH_MYSQL}
+IGNORE_WITH_MYSQL=${BROKEN_WITH_MYSQL}
+.endif
+.if defined(IGNORE_WITH_MYSQL)
+. for VER in ${IGNORE_WITH_MYSQL}
. if (${MYSQL_VER} == "${VER}")
-IGNORE= cannot install: doesn't work with MySQL version : ${MYSQL_VER} (Doesn't support MySQL ${BROKEN_WITH_MYSQL})
+IGNORE= cannot install: doesn't work with MySQL version : ${MYSQL_VER} (Doesn't support MySQL ${IGNORE_WITH_MYSQL})
. endif
. endfor
-.endif # BROKEN_WITH_MYSQL
+.endif # IGNORE_WITH_MYSQL
LIB_DEPENDS+= mysqlclient.${MYSQL${MYSQL_VER}_LIBVER}:${PORTSDIR}/databases/mysql${MYSQL_VER}-client
.else
IGNORE= cannot install: unknown MySQL version: ${MYSQL_VER}
@@ -155,13 +159,17 @@ PGSQL_VER= ${DEFAULT_PGSQL_VER}
# And now we are checking if we can use it
.if defined(PGSQL${PGSQL_VER}_LIBVER)
+# compatability shim
.if defined(BROKEN_WITH_PGSQL)
-. for VER in ${BROKEN_WITH_PGSQL}
+IGNORE_WITH_PGSQL=${BROKEN_WITH_PGSQL}
+.endif
+.if defined(IGNORE_WITH_PGSQL)
+. for VER in ${IGNORE_WITH_PGSQL}
. if (${PGSQL_VER} == "${VER}")
-IGNORE= cannot install: does not work with postgresql${PGSQL_VER}-client PostgresSQL (${BROKEN_WITH_PGSQL} not supported)
+IGNORE= cannot install: does not work with postgresql${PGSQL_VER}-client PostgresSQL (${IGNORE_WITH_PGSQL} not supported)
. endif
. endfor
-.endif # BROKEN_WITH_PGSQL
+.endif # IGNORE_WITH_PGSQL
LIB_DEPENDS+= pq.${PGSQL${PGSQL_VER}_LIBVER}:${PORTSDIR}/databases/postgresql${PGSQL_VER}-client
.else
IGNORE= cannot install: unknown PostgreSQL version: ${PGSQL_VER}
@@ -220,7 +228,7 @@ _WANT_BDB_VER= 41+
# Detect bdb version
_BDB_VER= no
-_BDB_BROKEN= no
+_BDB_IGNORE= no
# Override the user defined WITH_BDB_VER with the WANT_BDB_VER
.if defined(WANT_BDB_VER)
@@ -242,7 +250,7 @@ _BDB_VER= ${bdb}
. for dbx in ${_DB_${_MATCHED_DB_VER}P}
. if exists(${db${dbx}_FIND})
_BRKDB= no
-# Skip versions we are broken with
+# Skip versions we are incompatible with
. if defined(INVALID_BDB_VER)
_CHK_BDB:= ${dbx}
. for BRKDB in ${INVALID_BDB_VER}
@@ -282,20 +290,20 @@ _CHK_PLUS:= ${VER:S/+//}
# INVALID_BDB_VER is specified as VER+
. if ${_CHK_PLUS} != "${VER}"
. if ${_BDB_VER} == "${_CHK_PLUS}
-_BDB_BROKEN= yes
+_BDB_IGNORE= yes
. else
. for VER_P in ${_DB_${_CHK_PLUS}P}
. if ${_BDB_VER} == "${VER_P}"
-_BDB_BROKEN= yes
+_BDB_IGNORE= yes
. endif
. endfor
. endif
. elif ${_BDB_VER} == "${VER}"
-_BDB_BROKEN= yes
+_BDB_IGNORE= yes
. endif
. endfor
. endif
-. if ${_BDB_BROKEN} == "yes"
+. if ${_BDB_IGNORE} == "yes"
IGNORE= cannot install: does not work with bdb version: ${_BDB_VER} (${INVALID_BDB_VER} not supported)
. else
# Now add the dependancy on Berkeley DB ${_BDB_VER) version