aboutsummaryrefslogtreecommitdiffstats
path: root/Mk/bsd.database.mk
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2014-11-04 16:21:55 +0800
committermarino <marino@FreeBSD.org>2014-11-04 16:21:55 +0800
commitc2e93851da6a0b78c5fc2e0258f3b1930925e167 (patch)
tree72ab3bccf2944cb7cd4cc6703c6db257586e3e02 /Mk/bsd.database.mk
parent6cddfa60f6db7f1b963efe20e408504f064d2258 (diff)
downloadfreebsd-ports-gnome-c2e93851da6a0b78c5fc2e0258f3b1930925e167.tar.gz
freebsd-ports-gnome-c2e93851da6a0b78c5fc2e0258f3b1930925e167.tar.zst
freebsd-ports-gnome-c2e93851da6a0b78c5fc2e0258f3b1930925e167.zip
Add new ports databases/mariadb100-server and -client (version 10.0)
PR: 193539 Submitted by: spil.oss (gmail) MariaDB is a database server that offers drop-in replacement functionality for MySQL. MariaDB is built by some of the original authors of MySQL, with assistance from the broader community of Free and open source software developers. In addition to the core functionality of MySQL, MariaDB offers a rich set of feature enhancements including alternate storage engines, server optimizations, and patches.
Diffstat (limited to 'Mk/bsd.database.mk')
-rw-r--r--Mk/bsd.database.mk6
1 files changed, 5 insertions, 1 deletions
diff --git a/Mk/bsd.database.mk b/Mk/bsd.database.mk
index 9f4342078fd3..68eb5bd4d6bf 100644
--- a/Mk/bsd.database.mk
+++ b/Mk/bsd.database.mk
@@ -129,10 +129,11 @@ MYSQL55m_LIBVER= 18
MYSQL55p_LIBVER= 18
MYSQL56_LIBVER= 18
MYSQL56p_LIBVER= 18
+MYSQL100m_LIBVER= 18
# Setting/finding MySQL version we want.
.if exists(${LOCALBASE}/bin/mysql)
-_MYSQL!= ${LOCALBASE}/bin/mysql --version | ${SED} -e 's/.*Distrib \([0-9]\)\.\([0-9]*\).*/\1\2/'
+_MYSQL!= ${LOCALBASE}/bin/mysql --version | ${SED} -e 's/.*Distrib \([0-9]\{1,2\}\)\.\([0-9]*\).*/\1\2/'
_PERCONA!= ${LOCALBASE}/bin/mysql --version | ${GREP} Percona | wc -l
_MARIADB!= ${LOCALBASE}/bin/mysql --version | ${GREP} MariaDB | wc -l
@@ -172,6 +173,9 @@ _MYSQL_SERVER= databases/mariadb-server
.elif (${MYSQL_VER} == "55m")
_MYSQL_CLIENT= databases/mariadb55-client
_MYSQL_SERVER= databases/mariadb55-server
+.elif (${MYSQL_VER} == "100m")
+_MYSQL_CLIENT= databases/mariadb100-client
+_MYSQL_SERVER= databases/mariadb100-server
.elif (${MYSQL_VER} == "55p")
_MYSQL_CLIENT= databases/percona55-client
_MYSQL_SERVER= databases/percona55-server