aboutsummaryrefslogtreecommitdiffstats
path: root/Mk/bsd.fpc.mk
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2014-05-05 17:45:36 +0800
committerbapt <bapt@FreeBSD.org>2014-05-05 17:45:36 +0800
commit1fa39fd2c3d6f5edbc6d4a9d6f9ceae142a0f184 (patch)
tree96cc94ba02edcc043c52eb3f26adbc632bbe44d8 /Mk/bsd.fpc.mk
parentd8575795a2106dcbddc552f756cb3916f113f9e0 (diff)
downloadfreebsd-ports-gnome-1fa39fd2c3d6f5edbc6d4a9d6f9ceae142a0f184.tar.gz
freebsd-ports-gnome-1fa39fd2c3d6f5edbc6d4a9d6f9ceae142a0f184.tar.zst
freebsd-ports-gnome-1fa39fd2c3d6f5edbc6d4a9d6f9ceae142a0f184.zip
Convert all :U to :tu and :L to :tl
Since FreeBSD 8.4 and FreeBSD 9.1 make(1) do support :tu and :tl as a replacement for :U and :L (which has been marked as deprecated) bmake which is the default on FreeBSD 10+ only support by default :tu/:tl a hack has been added at the time to support :U and :L to ease migration. This hack is now not necessary anymore Note that this makes the ports tree incompatible with make(1) from FreeBSD 8.3 or earlier With hat: portmgr
Diffstat (limited to 'Mk/bsd.fpc.mk')
-rw-r--r--Mk/bsd.fpc.mk6
1 files changed, 3 insertions, 3 deletions
diff --git a/Mk/bsd.fpc.mk b/Mk/bsd.fpc.mk
index d390e52ad04c..6f27465c268f 100644
--- a/Mk/bsd.fpc.mk
+++ b/Mk/bsd.fpc.mk
@@ -75,7 +75,7 @@ _FPC_ALL_UNITS= a52 aspell bfd bzip2 cairo chm dblib dbus dts fastcgi fcl-async
_FPC_CFG_UNITS= fastcgi fcl-web
.if defined(WANT_FPC_BASE)
-. if ${WANT_FPC_BASE:L} == "yes"
+. if ${WANT_FPC_BASE:tl} == "yes"
USE_FPC= gdbint graph hash httpd22 httpd24 ibase mysql odbc oracle pasjpeg paszlib \
postgres pthreads regexpr sqlite
. else
@@ -84,14 +84,14 @@ IGNORE= unknown value, please use "yes" instead of
.endif
.if defined(WANT_FPC_ALL)
-. if ${WANT_FPC_ALL:L} == "yes"
+. if ${WANT_FPC_ALL:tl} == "yes"
USE_FPC= ${_FPC_ALL_UNITS}
. else
IGNORE= unknown value, please use "yes" instead of
. endif
.endif
-.if ${USE_FPC:L} != "yes"
+.if ${USE_FPC:tl} != "yes"
. for UNITS in ${USE_FPC}
. if ${_FPC_ALL_UNITS:M${UNITS}}==""
IGNORE= cannot install: unknown FPC unit ${UNITS}