aboutsummaryrefslogtreecommitdiffstats
path: root/Mk/bsd.gcc.mk
diff options
context:
space:
mode:
authorgerald <gerald@FreeBSD.org>2013-03-16 21:01:12 +0800
committergerald <gerald@FreeBSD.org>2013-03-16 21:01:12 +0800
commit620d23d5d634c583137ede5dafcaaf69595a5068 (patch)
tree9f49c20b4f310452158bf6a4ea9250b2f991695d /Mk/bsd.gcc.mk
parentb9cdaaea780a8cf76af678f31044a5cc947163d5 (diff)
downloadfreebsd-ports-gnome-620d23d5d634c583137ede5dafcaaf69595a5068.tar.gz
freebsd-ports-gnome-620d23d5d634c583137ede5dafcaaf69595a5068.tar.zst
freebsd-ports-gnome-620d23d5d634c583137ede5dafcaaf69595a5068.zip
Simplify (and strictly speaking, though not practically given version
number schemes between FreeBSD and GCC, correct) the check for a valid version specified by USE_GCC. [1] If IGNORE is set, have test-gcc note that instead of showing its usual, and in that case incorrect and useless, debugging output. PR: 175252 [1] Submitted by: Yamaya Takashi <yamayan@kbh.biglobe.ne.jp> [1]
Diffstat (limited to 'Mk/bsd.gcc.mk')
-rw-r--r--Mk/bsd.gcc.mk10
1 files changed, 6 insertions, 4 deletions
diff --git a/Mk/bsd.gcc.mk b/Mk/bsd.gcc.mk
index c4f494f8d6ea..b3a6ebab6463 100644
--- a/Mk/bsd.gcc.mk
+++ b/Mk/bsd.gcc.mk
@@ -131,11 +131,9 @@ _GCC_ORLATER:= true
# Check if USE_GCC points to a valid version.
.for v in ${GCCVERSIONS}
-. for j in ${GCCVERSION_${v}}
-. if ${_USE_GCC}==${j}
+. if ${_USE_GCC}==${_GCCVERSION_${v}_V}
_GCCVERSION_OKAY= true;
-. endif
-. endfor
+. endif
.endfor
.if !defined(_GCCVERSION_OKAY)
@@ -251,6 +249,9 @@ USE_BINUTILS= yes
test-gcc:
@echo USE_GCC=${USE_GCC}
@echo USE_FORTRAN=${USE_FORTRAN}
+.if defined(IGNORE)
+ @echo "IGNORE: ${IGNORE}"
+.else
.if defined(USE_GCC)
.if defined(_GCC_ORLATER)
@echo Port can use later versions.
@@ -272,3 +273,4 @@ test-gcc:
@echo LDFLAGS=\"${LDFLAGS}\"
@echo "BUILD_DEPENDS=${BUILD_DEPENDS}"
@echo "RUN_DEPENDS=${RUN_DEPENDS}"
+.endif