aboutsummaryrefslogtreecommitdiffstats
path: root/Mk/bsd.gcc.mk
diff options
context:
space:
mode:
authorgerald <gerald@FreeBSD.org>2010-10-17 19:24:50 +0800
committergerald <gerald@FreeBSD.org>2010-10-17 19:24:50 +0800
commit613de721166d3d9bc46ca1d0b2263a4c5f319696 (patch)
tree1242cf2a9e5bf8a5d0b20249eda11734f69749f3 /Mk/bsd.gcc.mk
parentadb1b9166cead01b5319edf64a831096e3b6fafb (diff)
downloadfreebsd-ports-gnome-613de721166d3d9bc46ca1d0b2263a4c5f319696.tar.gz
freebsd-ports-gnome-613de721166d3d9bc46ca1d0b2263a4c5f319696.tar.zst
freebsd-ports-gnome-613de721166d3d9bc46ca1d0b2263a4c5f319696.zip
Simplify the case of USE_FORTRAN=g77. Update a comment.
Discussed with: bf
Diffstat (limited to 'Mk/bsd.gcc.mk')
-rw-r--r--Mk/bsd.gcc.mk12
1 files changed, 4 insertions, 8 deletions
diff --git a/Mk/bsd.gcc.mk b/Mk/bsd.gcc.mk
index 0d2d45b977e5..4f73d7959309 100644
--- a/Mk/bsd.gcc.mk
+++ b/Mk/bsd.gcc.mk
@@ -65,10 +65,9 @@ _GCCVERSION_${v}_V= ${j}
. endfor
.endfor
-#
-# bsd.gcc.mk can also be used only for FC, F77 settings; in this case we
-# do not define USE_GCC.
-#
+# bsd.gcc.mk can also be used for primarily requesting a Fortran compiler.
+# If we are using GCC we still define whatever we'd usually do for C and
+# C++ as well.
.if defined (USE_FORTRAN)
@@ -89,12 +88,9 @@ F77:= ${LOCALBASE}/intel_fc_80/bin/ifort
# (FreeBSD<=6).
. elif ${USE_FORTRAN} == g77
. if (${OSVERSION} > 700042)
-BUILD_DEPENDS+= g77-34:${PORTSDIR}/lang/gcc34
-RUN_DEPENDS+= g77-34:${PORTSDIR}/lang/gcc34
+_USE_GCC:= 3.4
FC:= g77-34
F77:= g77-34
-CC:= gcc34
-CXX:= g++34
. else
F77:= f77
FC:= f77