aboutsummaryrefslogtreecommitdiffstats
path: root/Mk/bsd.gcc.mk
diff options
context:
space:
mode:
authorgerald <gerald@FreeBSD.org>2009-09-26 09:02:01 +0800
committergerald <gerald@FreeBSD.org>2009-09-26 09:02:01 +0800
commit65e1e11bfa826f04010ac542677ad401430c779e (patch)
tree40f836927a86dce57f48b920f6bdeecce4459628 /Mk/bsd.gcc.mk
parentb7507ace522172c2b055ae61fb7c216e4a4f3487 (diff)
downloadfreebsd-ports-gnome-65e1e11bfa826f04010ac542677ad401430c779e.tar.gz
freebsd-ports-gnome-65e1e11bfa826f04010ac542677ad401430c779e.tar.zst
freebsd-ports-gnome-65e1e11bfa826f04010ac542677ad401430c779e.zip
Have CFLAGS and LDFLAGS set an -rpath to the lang/gcc44 library directory
when building with USE_FORTRAN=yes. This makes us use libstdc++.so.6 (and others) brought by this port as opposed to /usr/bin/libstdc++.so.6 that comes with our system compiler which is based on an older version of GCC 4.2. Newer version of GCC run-time libraries with the same soname are always backwards compatible. Feature safe: yes
Diffstat (limited to 'Mk/bsd.gcc.mk')
-rw-r--r--Mk/bsd.gcc.mk2
1 files changed, 2 insertions, 0 deletions
diff --git a/Mk/bsd.gcc.mk b/Mk/bsd.gcc.mk
index 8e4f48f16b83..f4854874a445 100644
--- a/Mk/bsd.gcc.mk
+++ b/Mk/bsd.gcc.mk
@@ -72,6 +72,8 @@ FC:= gfortran44
F77:= gfortran44
CC:= gcc44
CXX:= g++44
+CFLAGS+= -Wl,-rpath=${PREFIX}/lib/gcc44
+LDFLAGS+= -Wl,-rpath=${PREFIX}/lib/gcc44
# Intel Fortran compiler from lang/ifc.
. elif ${USE_FORTRAN} == ifort