aboutsummaryrefslogtreecommitdiffstats
path: root/Mk/bsd.gcc.mk
diff options
context:
space:
mode:
authorgerald <gerald@FreeBSD.org>2008-06-29 00:52:40 +0800
committergerald <gerald@FreeBSD.org>2008-06-29 00:52:40 +0800
commit789f943eb9c2254f9c7726d67b6397ce2b2390d9 (patch)
tree00afd343a852c1f1a9d4febdcbcfc8634e26dd77 /Mk/bsd.gcc.mk
parent613656c1f66fa0ab04bb72c852946b230aa60d79 (diff)
downloadfreebsd-ports-gnome-789f943eb9c2254f9c7726d67b6397ce2b2390d9.tar.gz
freebsd-ports-gnome-789f943eb9c2254f9c7726d67b6397ce2b2390d9.tar.zst
freebsd-ports-gnome-789f943eb9c2254f9c7726d67b6397ce2b2390d9.zip
Provide the test-gcc target and at least key information there even if
USE_GCC has not been specified. This is relevant for USE_FORTRAN, but should be useful in general.
Diffstat (limited to 'Mk/bsd.gcc.mk')
-rw-r--r--Mk/bsd.gcc.mk12
1 files changed, 9 insertions, 3 deletions
diff --git a/Mk/bsd.gcc.mk b/Mk/bsd.gcc.mk
index c51ac2b677e7..7fad94aa145b 100644
--- a/Mk/bsd.gcc.mk
+++ b/Mk/bsd.gcc.mk
@@ -99,7 +99,9 @@ FC:= f77
MAKE_ENV+= F77="${F77}" FC="${FC}" FFLAGS="${FFLAGS}"
.endif
+
.if defined(USE_GCC)
+
# See if we can use a later version
_USE_GCC:= ${USE_GCC:S/+//}
.if ${USE_GCC} != ${_USE_GCC}
@@ -190,21 +192,25 @@ CXX:= g++${V}
.endfor
.undef V
-
.if defined(_GCC_BUILD_DEPENDS)
BUILD_DEPENDS+= ${_GCC_PORT_DEPENDS}:${PORTSDIR}/lang/${_GCC_BUILD_DEPENDS}
.endif
MAKE_ENV+= CC="${CC}" CXX="${CXX}" CFLAGS="${CFLAGS}"
+.endif
+# defined(USE_GCC)
+
+
test-gcc:
@echo USE_GCC=${USE_GCC}
+ @echo USE_FORTRAN=${USE_FORTRAN}
+.if defined(USE_GCC)
.if defined(_GCC_ORLATER)
@echo Port can use later versions.
.else
@echo Port cannot use later versions.
.endif
- @echo USE_FORTRAN=${USE_FORTRAN}
.for v in ${GCCVERSIONS}
@echo -n "GCC version: ${_GCCVERSION_${v}_V} "
.if defined(_GCC_FOUND${v})
@@ -214,7 +220,7 @@ test-gcc:
# @echo ${v} - ${_GCC_FOUND${v}} - ${_GCCVERSION_${v}_L} to ${_GCCVERSION_${v}_R} - ${_GCCVERSION_${v}_V}
.endfor
@echo Using GCC version ${_USE_GCC}
+.endif
@echo CC=${CC} - CXX=${CXX} - CFLAGS=${CFLAGS}
@echo F77=${F77} - FC=${FC} - FFLAGS=${FFLAGS}
@echo BUILD_DEPENDS=${BUILD_DEPENDS}
-.endif