aboutsummaryrefslogtreecommitdiffstats
path: root/Mk/bsd.gecko.mk
diff options
context:
space:
mode:
authorjbeich <jbeich@FreeBSD.org>2016-09-08 14:48:53 +0800
committerjbeich <jbeich@FreeBSD.org>2016-09-08 14:48:53 +0800
commit0554eadc5b29001492f3f005808e9e87140bbbdc (patch)
tree03ae9cefeab6b81f0b2625dfaca8d7a7aef28fc9 /Mk/bsd.gecko.mk
parentf742a4db4bdefe638a9c82bfea1e3cac0f335741 (diff)
downloadfreebsd-ports-gnome-0554eadc5b29001492f3f005808e9e87140bbbdc.tar.gz
freebsd-ports-gnome-0554eadc5b29001492f3f005808e9e87140bbbdc.tar.zst
freebsd-ports-gnome-0554eadc5b29001492f3f005808e9e87140bbbdc.zip
www/firefox: update to 49.0 (rc2)
Bump PORTREVISION to account for slightly different behavior in other gecko@ ports and to get a discrete regression window. Changes: https://www.mozilla.org/firefox/49.0/releasenotes/ PR: 211792 Submitted by: Jochen Neumeister <joneum@bsdproject.de> (based on) Security: 2c57c47e-8bb3-4694-83c8-9fc3abad3964 MFH: 2016Q3
Diffstat (limited to 'Mk/bsd.gecko.mk')
-rw-r--r--Mk/bsd.gecko.mk32
1 files changed, 15 insertions, 17 deletions
diff --git a/Mk/bsd.gecko.mk b/Mk/bsd.gecko.mk
index 83c18aac55a9..99aad151e547 100644
--- a/Mk/bsd.gecko.mk
+++ b/Mk/bsd.gecko.mk
@@ -95,12 +95,18 @@ USE_XORG= x11 xcomposite xdamage xext xfixes xrender xt
BUNDLE_LIBS= yes
.endif
+# call to implicitly-deleted copy constructor of 'mozilla::WidevineVideoFrame'
+. if ${OPSYS} == FreeBSD && ${OSVERSION} < 1000019 && ${MOZILLA_VER:R:R} >= 49
+# XXX USES=compiler:c++11-lib cannot be used due to ports/208538
+USE_GCC= 5+
+.endif
+
MOZILLA_SUFX?= none
MOZSRC?= ${WRKSRC}
WRKSRC?= ${WRKDIR}/mozilla
PLISTF?= ${WRKDIR}/plist_files
-MOZ_OBJDIR?= ${WRKSRC}/obj-${CONFIGURE_TARGET}
+MOZ_OBJDIR?= ${WRKSRC}/obj-${ARCH:C/amd64/x86_64/}-unknown-${OPSYS:tl}${OSREL}
MOZ_PIS_DIR?= lib/${MOZILLA}/init.d
@@ -119,10 +125,9 @@ MOZ_PKGCONFIG_FILES?= ${MOZILLA}-gtkmozembed ${MOZILLA}-js \
ALL_TARGET?= build
-CONFIGURE_TARGET:=${ARCH:C/amd64/x86_64/}-portbld-${OPSYS:tl}${OSREL}
MOZ_EXPORT+= ${CONFIGURE_ENV} \
PERL="${PERL}"
-MOZ_OPTIONS+= ${CONFIGURE_TARGET} --prefix="${PREFIX}"
+MOZ_OPTIONS+= --prefix="${PREFIX}"
MOZ_MK_OPTIONS+=MOZ_OBJDIR="${MOZ_OBJDIR}"
CPPFLAGS+= -isystem${LOCALBASE}/include
@@ -138,7 +143,11 @@ MOZ_EXPORT+= MOZ_JEMALLOC3=1 MOZ_JEMALLOC4=1
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-bug1125514
. endif
.elif ${OPSYS} != FreeBSD || ${OSVERSION} < 1000012 || ${MOZILLA_VER:R:R} >= 37
+. if ${MOZILLA_VER:R:R} >= 48
+MOZ_OPTIONS+= --enable-jemalloc=4
+.else
MOZ_OPTIONS+= --enable-jemalloc
+. endif
.endif
.endif # !DragonFly
@@ -265,14 +274,7 @@ MOZ_OPTIONS+= --enable-necko-protocols=${MOZ_PROTOCOLS}
# others
MOZ_OPTIONS+= --with-system-zlib \
--with-system-bz2 \
- --enable-unified-compilation \
- --disable-debug-symbols \
- --disable-glibtest \
- --disable-gtktest \
- --disable-freetypetest \
- --disable-installer \
- --disable-updater \
- --disable-pedantic
+ --disable-debug-symbols
# API keys from www/chromium
# http://www.chromium.org/developers/how-tos/api-keys
@@ -301,10 +303,6 @@ CFLAGS+= -O3
MOZ_EXPORT+= MOZ_OPTIMIZE_FLAGS="${CFLAGS:M-O*}"
MOZ_OPTIONS+= --enable-optimize
.else
-. if ${MOZILLA_VER:R:R} >= 45 && ${ARCH} == i386 && \
- (${OSVERSION} >= 1000000 && ${OSVERSION} < 1003501)
-USES:= compiler:c++14-lang ${USES:Ncompiler*c++11*} # XXX ports/207837
-. endif
MOZ_OPTIONS+= --disable-optimize
.endif
@@ -319,7 +317,7 @@ LIB_DEPENDS+= libdbus-1.so:devel/dbus \
libstartup-notification-1.so:x11/startup-notification
MOZ_OPTIONS+= --enable-startup-notification
.else
-MOZ_OPTIONS+= --disable-dbus --disable-libnotify
+MOZ_OPTIONS+= --disable-dbus
.endif
.if ${PORT_OPTIONS:MFFMPEG}
@@ -331,7 +329,7 @@ RUN_DEPENDS+= ffmpeg>=0.8,1:multimedia/ffmpeg
RUN_DEPENDS+= gstreamer1-libav>=1.2.4_1:multimedia/gstreamer1-libav
USE_GSTREAMER1?=good libav
MOZ_OPTIONS+= --enable-gstreamer=1.0
-.else
+.elif ${MOZILLA_VER:R:R} < 46
MOZ_OPTIONS+= --disable-gstreamer
.endif