aboutsummaryrefslogtreecommitdiffstats
path: root/Mk/bsd.gecko.mk
diff options
context:
space:
mode:
authorflo <flo@FreeBSD.org>2011-06-29 00:34:23 +0800
committerflo <flo@FreeBSD.org>2011-06-29 00:34:23 +0800
commit74af39c955f63a73cd1765adcd81ccbe72144ba4 (patch)
tree6a375fc50db5218d3a4b8030909529c7fbac0d14 /Mk/bsd.gecko.mk
parent4ed57473907491a49f2999a804878a55a6b2702a (diff)
downloadfreebsd-ports-gnome-74af39c955f63a73cd1765adcd81ccbe72144ba4.tar.gz
freebsd-ports-gnome-74af39c955f63a73cd1765adcd81ccbe72144ba4.tar.zst
freebsd-ports-gnome-74af39c955f63a73cd1765adcd81ccbe72144ba4.zip
- disable debug symbols for the gecko ports and enable striping of
libraries and binaries otherwise firefox and thunderbird >= 5 will install a libxul.so which can be as big as 500MB PR: ports/158380 Submitted by: Pan Tsu <inyaoo@gmail.com>
Diffstat (limited to 'Mk/bsd.gecko.mk')
-rw-r--r--Mk/bsd.gecko.mk3
1 files changed, 3 insertions, 0 deletions
diff --git a/Mk/bsd.gecko.mk b/Mk/bsd.gecko.mk
index 8e42b082c136..f76f49a9efc4 100644
--- a/Mk/bsd.gecko.mk
+++ b/Mk/bsd.gecko.mk
@@ -638,6 +638,7 @@ MOZ_OPTIONS+= --enable-necko-protocols=${MOZ_PROTOCOLS}
MOZ_OPTIONS+= --with-system-zlib=/usr \
--with-gssapi=${KRB5_HOME} \
--disable-auto-deps \
+ --disable-debug-symbols \
--enable-chrome-format=jar \
--disable-cpp-exceptions \
--disable-cpp-rtti \
@@ -673,6 +674,8 @@ MOZ_OPTIONS+= --disable-gnomevfs
.if !defined(STRIP) || ${STRIP} == ""
MOZ_OPTIONS+= --disable-strip --disable-install-strip
+.else
+MOZ_OPTIONS+= --enable-strip --enable-install-strip
.endif
.if defined(WITH_DEBUG)