aboutsummaryrefslogtreecommitdiffstats
path: root/Mk/bsd.gecko.mk
diff options
context:
space:
mode:
authorbeat <beat@FreeBSD.org>2011-10-20 00:00:44 +0800
committerbeat <beat@FreeBSD.org>2011-10-20 00:00:44 +0800
commit8cf74c1d3680e153dc23e9dd3aeb8932a889483d (patch)
tree8e1a12a37eceaac491a8a473d01cb88764513e5b /Mk/bsd.gecko.mk
parent18230f033f97fadb0ce910a7baf4d12f37624a3d (diff)
downloadfreebsd-ports-gnome-8cf74c1d3680e153dc23e9dd3aeb8932a889483d.tar.gz
freebsd-ports-gnome-8cf74c1d3680e153dc23e9dd3aeb8932a889483d.tar.zst
freebsd-ports-gnome-8cf74c1d3680e153dc23e9dd3aeb8932a889483d.zip
- Remove www/seamonkey2 and www/seamonkey2-i18n: Upstream support dropped
and multiple vulnerabilities.
Diffstat (limited to 'Mk/bsd.gecko.mk')
-rw-r--r--Mk/bsd.gecko.mk12
1 files changed, 4 insertions, 8 deletions
diff --git a/Mk/bsd.gecko.mk b/Mk/bsd.gecko.mk
index 6b3ae12b0e58..d78e57e70111 100644
--- a/Mk/bsd.gecko.mk
+++ b/Mk/bsd.gecko.mk
@@ -192,7 +192,7 @@ Gecko_Pre_Include= bsd.gecko.mk
# version is given by the maintainer via the port
# or by the user via defined variable try to find
# the highest stable installed version.
-# Available values: yes 24+ 20+ 24 20
+# Available values: yes 24+ 24
# NOTE:
# default value 24 is used in case of USE_SEAMONKEY=yes
#
@@ -296,12 +296,11 @@ _SEAMONKEY_BUILD_DEPENDS= yes
.endif
_SEAMONKEY_DEFAULT_VERSION= 24
-_SEAMONKEY_VERSIONS= 24 20
-_SEAMONKEY_RANGE_VERSIONS= 24+ 20+
+_SEAMONKEY_VERSIONS= 24
+_SEAMONKEY_RANGE_VERSIONS= 24+
# For specifying [24, 20, ..]+
-_SEAMONKEY_24P= 24 ${_SEAMONKEY_20P}
-_SEAMONKEY_20P= 20
+_SEAMONKEY_24P= 24
# Set the default SeaMonkey version and check if USE_SEAMONKEY=yes was given
.if ${USE_SEAMONKEY} == "yes"
@@ -311,8 +310,6 @@ USE_SEAMONKEY= ${_SEAMONKEY_DEFAULT_VERSION}
# Setting/finding SeaMonkey version we want.
.if exists(${LOCALBASE}/bin/seamonkey)
_SEAMONKEY_VER!= ${LOCALBASE}/bin/seamonkey --version 2>/dev/null | ${HEAD} -1 | ${SED} -e 's/Mozilla SeaMonkey \([0-9]\)\.\([0-9]*\).*/\1\2/'
-.elif exists(${LOCALBASE}/bin/seamonkey2)
-_SEAMONKEY_VER!= ${LOCALBASE}/bin/seamonkey2 --version 2>/dev/null | ${HEAD} -1 | ${SED} -e 's/Mozilla SeaMonkey \([0-9]\)\.\([0-9]*\).*/\1\2/'
.endif
# Check if installed SeaMonkey version matches the wanted one
@@ -346,7 +343,6 @@ IGNORE= cannot install: unknown SeaMonkey version: seamonkey-${USE_SEAMONKEY:C
# Dependence lines for different SeaMonkey versions
24_DEPENDS= ${LOCALBASE}/lib/seamonkey/seamonkey:${PORTSDIR}/www/seamonkey
-20_DEPENDS= ${LOCALBASE}/lib/seamonkey2/seamonkey:${PORTSDIR}/www/seamonkey2
# Add dependencies
.if defined(USE_SEAMONKEY)