aboutsummaryrefslogtreecommitdiffstats
path: root/Mk/bsd.gecko.mk
diff options
context:
space:
mode:
authorjbeich <jbeich@FreeBSD.org>2017-11-28 06:02:29 +0800
committerjbeich <jbeich@FreeBSD.org>2017-11-28 06:02:29 +0800
commita38a1342f01b1ae5edb99580dc83310e9ab5e404 (patch)
tree3d66af70b6fe803c5deca7c6f3517c47fc018d8b /Mk/bsd.gecko.mk
parentf8ad3798f3a69930e2b4c1496c67056c1f2b3d7c (diff)
downloadfreebsd-ports-gnome-a38a1342f01b1ae5edb99580dc83310e9ab5e404.tar.gz
freebsd-ports-gnome-a38a1342f01b1ae5edb99580dc83310e9ab5e404.tar.zst
freebsd-ports-gnome-a38a1342f01b1ae5edb99580dc83310e9ab5e404.zip
lang/rust: avoid LLVM targeting SSE2 on i386 by default
This may help ports like textproc/ripgrep to run on old hardware. Rust itself still requires SSE2 until bootstrap is regenerated. PR: 223415 Approved by: rust (dumbbell)
Diffstat (limited to 'Mk/bsd.gecko.mk')
-rw-r--r--Mk/bsd.gecko.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/Mk/bsd.gecko.mk b/Mk/bsd.gecko.mk
index 934a49eb8ee0..e4ded78f43de 100644
--- a/Mk/bsd.gecko.mk
+++ b/Mk/bsd.gecko.mk
@@ -395,7 +395,7 @@ MOZ_OPTIONS+= --enable-debug --disable-release
STRIP= # ports/184285
.else
MOZ_OPTIONS+= --disable-debug --disable-debug-symbols --enable-release
-. if ${MOZILLA_VER:R:R} >= 56
+. if ${MOZILLA_VER:R:R} >= 56 && (${MACHINE_CPU:Msse2} || ${ARCH:Maarch64})
MOZ_OPTIONS+= --enable-rust-simd
. endif
.endif