aboutsummaryrefslogtreecommitdiffstats
path: root/Mk/bsd.gecko.mk
diff options
context:
space:
mode:
authorjbeich <jbeich@FreeBSD.org>2015-12-16 17:38:29 +0800
committerjbeich <jbeich@FreeBSD.org>2015-12-16 17:38:29 +0800
commit748ce085e970783f6b8b18496228728bc1294c4c (patch)
tree7cfd95711b12f55f307840366326134034f9567b /Mk/bsd.gecko.mk
parenta2b1a5a4be9bd3306e1fb0f1076b057e5905cc8a (diff)
downloadfreebsd-ports-gnome-748ce085e970783f6b8b18496228728bc1294c4c.tar.gz
freebsd-ports-gnome-748ce085e970783f6b8b18496228728bc1294c4c.tar.zst
freebsd-ports-gnome-748ce085e970783f6b8b18496228728bc1294c4c.zip
gecko: drop support for libc++ where it's not default
If it still has an effect the compiler should be fixed instead.
Diffstat (limited to 'Mk/bsd.gecko.mk')
-rw-r--r--Mk/bsd.gecko.mk6
1 files changed, 1 insertions, 5 deletions
diff --git a/Mk/bsd.gecko.mk b/Mk/bsd.gecko.mk
index a5d1261fac75..45bbc2e9889e 100644
--- a/Mk/bsd.gecko.mk
+++ b/Mk/bsd.gecko.mk
@@ -466,13 +466,9 @@ MOZCONFIG_SED?= ${SED} ${MOZ_SED_ARGS}
USE_BINUTILS= # intel-gcm.s
CFLAGS+= -B${LOCALBASE}/bin
LDFLAGS+= -B${LOCALBASE}/bin
-. if ${OPSYS} == FreeBSD && ${OSVERSION} < 1000041 && \
- exists(/usr/lib/libcxxrt.so) && ${CXXFLAGS:M-stdlib=libc++}
-LIBS+= -lcxxrt
-. endif
-. endif
.elif ${ARCH:Mpowerpc*}
USES:= compiler:gcc-c++11-lib ${USES:Ncompiler*c++11*}
+.endif
. if ${ARCH} == "powerpc64"
MOZ_EXPORT+= UNAME_m="${ARCH}"
CFLAGS+= -mminimal-toc