aboutsummaryrefslogtreecommitdiffstats
path: root/Mk/bsd.gecko.mk
diff options
context:
space:
mode:
authorjbeich <jbeich@FreeBSD.org>2017-03-19 01:08:10 +0800
committerjbeich <jbeich@FreeBSD.org>2017-03-19 01:08:10 +0800
commitdee73475b642f0f82f0e4fb3642cc3b10ebcf575 (patch)
tree5bebbd876adc673d26209207913112eb6ba3c180 /Mk/bsd.gecko.mk
parent229811b3df7c7d442c8a0b428ce066b72392108a (diff)
downloadfreebsd-ports-gnome-dee73475b642f0f82f0e4fb3642cc3b10ebcf575.tar.gz
freebsd-ports-gnome-dee73475b642f0f82f0e4fb3642cc3b10ebcf575.tar.zst
freebsd-ports-gnome-dee73475b642f0f82f0e4fb3642cc3b10ebcf575.zip
gecko: define same update channel as official builds
Some addons rely on app.update.channel pref to enable features. One of those is e10srollout which controls Multiprocess Windows by default.
Diffstat (limited to 'Mk/bsd.gecko.mk')
-rw-r--r--Mk/bsd.gecko.mk2
1 files changed, 2 insertions, 0 deletions
diff --git a/Mk/bsd.gecko.mk b/Mk/bsd.gecko.mk
index 46232fe7276f..c3ce5e3aa0e3 100644
--- a/Mk/bsd.gecko.mk
+++ b/Mk/bsd.gecko.mk
@@ -250,9 +250,11 @@ BUILD_DEPENDS+= ${-${dep}_BUILD_DEPENDS}
# Standard options
MOZ_CHROME?= omni
MOZ_TOOLKIT?= cairo-gtk2
+MOZ_CHANNEL?= ${PKGNAMESUFFIX:Urelease:S/^-//}
MOZ_OPTIONS+= \
--enable-chrome-format=${MOZ_CHROME} \
--enable-default-toolkit=${MOZ_TOOLKIT} \
+ --enable-update-channel=${MOZ_CHANNEL} \
--enable-pie \
--with-pthreads
# Configure options for install