aboutsummaryrefslogtreecommitdiffstats
path: root/Mk/bsd.gnome.mk
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2003-04-12 09:12:57 +0800
committermarcus <marcus@FreeBSD.org>2003-04-12 09:12:57 +0800
commitb281be3dc5d8087634e136f33ba67fad81f7f991 (patch)
tree66f1a61f2d4a6e5dcbe6b509598d97aa1f9edf76 /Mk/bsd.gnome.mk
parent5817469c7e1e52b1ad3aee16b3b5fe25dc862334 (diff)
downloadfreebsd-ports-gnome-b281be3dc5d8087634e136f33ba67fad81f7f991.tar.gz
freebsd-ports-gnome-b281be3dc5d8087634e136f33ba67fad81f7f991.tar.zst
freebsd-ports-gnome-b281be3dc5d8087634e136f33ba67fad81f7f991.zip
Remove the global CONFIGURE_TARGET, and add it as a dependency of glib20.
Diffstat (limited to 'Mk/bsd.gnome.mk')
-rw-r--r--Mk/bsd.gnome.mk8
1 files changed, 5 insertions, 3 deletions
diff --git a/Mk/bsd.gnome.mk b/Mk/bsd.gnome.mk
index f7d03b372e7c..6477dfdf6f17 100644
--- a/Mk/bsd.gnome.mk
+++ b/Mk/bsd.gnome.mk
@@ -203,6 +203,7 @@ libpanel_GNOME_DESKTOP_VERSION=1
glib20_LIB_DEPENDS= glib-2.0.200:${PORTSDIR}/devel/glib20
glib20_DETECT= ${LOCALBASE}/libdata/pkgconfig/glib-2.0.pc
+glib20_CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
atk_LIB_DEPENDS= atk-1.0.200:${PORTSDIR}/devel/atk
atk_DETECT= ${LOCALBASE}/libdata/pkgconfig/atk.pc
@@ -452,9 +453,6 @@ USE_GNOME+= imlib
USE_GNOME+=gnomeprefix gnomehack gtkhtml libpanel
. endif
-# Set a reasonable (overrideable) configure target for GNOME apps.
-CONFIGURE_TARGET?= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-
# First of all expand all USE_GNOME_IMPL recursively
. for component in ${_USE_GNOME_ALL}
. for subcomponent in ${${component}_USE_GNOME_IMPL}
@@ -494,6 +492,10 @@ CONFIGURE_ARGS+=${${component}_CONFIGURE_ARGS}
CONFIGURE_ENV+= ${${component}_CONFIGURE_ENV}
MAKE_ENV+= ${${component}_MAKE_ENV}
+. if !defined(CONFIGURE_TARGET) && defined(${component}_CONFIGURE_TARGET)
+CONFIGURE_TARGET= ${${component}_CONFIGURE_TARGET}
+. endif
+
. if defined(${component}_PRE_PATCH)
GNOME_PRE_PATCH+= ${${component}_PRE_PATCH}
. endif