aboutsummaryrefslogtreecommitdiffstats
path: root/Mk/bsd.gnome.mk
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2004-01-20 17:14:10 +0800
committermarcus <marcus@FreeBSD.org>2004-01-20 17:14:10 +0800
commit9b747a6546b43692ef04ef91fe2d40b9d13ddcde (patch)
treea35e44fad8dbd6348f9b55672e3be34d62267529 /Mk/bsd.gnome.mk
parent7d8cb0c07b6cf936343a244b6330c2442937d54f (diff)
downloadfreebsd-ports-gnome-9b747a6546b43692ef04ef91fe2d40b9d13ddcde.tar.gz
freebsd-ports-gnome-9b747a6546b43692ef04ef91fe2d40b9d13ddcde.tar.zst
freebsd-ports-gnome-9b747a6546b43692ef04ef91fe2d40b9d13ddcde.zip
Here come the patches!
* Add ghostscript knobs [1] * Add per-port persistent build options with a menu-driven front-end [2] * Allow porters to override the message generated when do-configure fails [3] * Add patch to obviate many pkg-plist files [4] * Fix the PKG_DBDIR comment [5] * Make ports framework more robust with regard to make index [6] * Add new command macros to bsd.port.mk [7] * Remove direct command use from bsd.port.mk [8] * Make the ports system respect WITHOUT_CPU_CFLAGS [9] * Break the SDL code out into bsd.sdl.mk [10] * Add working support for USE_SIZE [11] * Fix RANDOMIZE_MASTER_SITES on -CURRENT [12] * Convert some spaces to tabs [13] * Add new physcial categories accessibility and x11-themes [14] * Speed up GNU configure scripts [15] * Remove "//" from MLINKS items in PLISTs and fix make -s install and make -s deinstall [16] * Be more specific about looking for files in distinfo [17] * Add new run-autotools target, and resort configure targets [18] * Make CONFLICTS compare prefix for installed packages and PREFIX [19] * Change directory to ${.CURDIR} before running certain make commands [20] * When INSTALL_AS_USER is set, run ldconfig with failures ignored [21] * Speed up the security check phase [22] * Fix some corner cases in the PORTDOCS code [23] * Add a new DEPRECATED macro [24] * Make INDEX breakage more informative [25] Look for a full write-up to follow on ports@ and ports-developers@. PR: 36112 [1] 59909 [4] 61351 [6] 59058 [7] 59058 [8] 59493 [9] 55494 [10] 59058 [11] 59315 [12] 59058 [13] 59811 [15] 59058 [16] 59058 [17] 60882 [18] 58149 [19] 59058 [20] 61133 [21] 55331 [22] 59070 [23] 59362 [24] 59626 [25] Submitted by: linimon [1] eivind [2] marcus [3] trevor [4] gerald [5] linimon [6] eik [7] eik [8] jeh [9] edwin [10] eik [11] Sergey Matveychuk <sem@ciam.ru> [12] eik [13] trevor gnome [14] adamw [15] eik [16] eik [17] edwin [18] clement [19] eik [20] edwin lev [21] Eugene M. Kim <ab@astralblue.com> [22] eik [23] linimon [24] eik [25]
Diffstat (limited to 'Mk/bsd.gnome.mk')
-rw-r--r--Mk/bsd.gnome.mk16
1 files changed, 4 insertions, 12 deletions
diff --git a/Mk/bsd.gnome.mk b/Mk/bsd.gnome.mk
index 6664b5cd85f8..4457d18c0f8a 100644
--- a/Mk/bsd.gnome.mk
+++ b/Mk/bsd.gnome.mk
@@ -26,7 +26,7 @@ Gnome_Include_MAINTAINER= gnome@FreeBSD.org
# non-version specific components
_USE_GNOME_ALL= gnomehack lthack gnomeprefix gnomehier esound gnomemimedata \
- gnometarget pkgconfig intltool intlhack
+ gnometarget pkgconfig intlhack
# GNOME 1 components
_USE_GNOME_ALL+=libghttp glib12 gtk12 libxml gdkpixbuf imlib orbit \
@@ -41,8 +41,7 @@ _USE_GNOME_ALL+=glib20 atk pango gtk20 linc libidl orbit2 \
libgnome libbonoboui libgnomeui atspi libgailgnome \
libgtkhtml gnomedesktop libwnck vte libzvt librsvg2 eel2 \
gnomepanel nautilus2 metacity gal2 gnomecontrolcenter2 libgda2 \
- libgnomedb gtksourceview libgsf pygtk2 pygnome2 gstreamerplugins \
- gtkhtml3
+ libgnomedb gtksourceview libgsf pygtk2 pygnome2 gstreamerplugins
SCROLLKEEPER_DIR= /var/db/scrollkeeper
gnomehack_PRE_PATCH= ${FIND} ${WRKSRC} -name "Makefile.in*" | ${XARGS} ${REINPLACE_CMD} -e \
@@ -234,7 +233,7 @@ pango_USE_GNOME_IMPL= glib20
gtk20_LIB_DEPENDS= gtk-x11-2.0.200:${PORTSDIR}/x11-toolkits/gtk20
gtk20_DETECT= ${X11BASE}/libdata/pkgconfig/gtk+-x11-2.0.pc
-gtk20_USE_GNOME_IMPL= intltool atk pango
+gtk20_USE_GNOME_IMPL= atk pango
linc_LIB_DEPENDS= linc.1:${PORTSDIR}/net/linc
linc_DETECT= ${LOCALBASE}/libdata/pkgconfig/linc.pc
@@ -398,17 +397,10 @@ gstreamerplugins_LIB_DEPENDS= gstplay-0.6.1:${PORTSDIR}/multimedia/gstreamer-plu
gstreamerplugins_DETECT= ${X11BASE}/libdata/pkgconfig/gstreamer-play-0.6.pc
gstreamerplugins_USE_GNOME_IMPL= gconf2
-intltool_DETECT= ${LOCALBASE}/bin/intltool-extract
-intltool_BUILD_DEPENDS= ${intltool_DETECT}:${PORTSDIR}/textproc/intltool
-
+intlhack_BUILD_DEPENDS= intltool-extract:${PORTSDIR}/textproc/intltool
intlhack_PRE_PATCH= ${FIND} ${WRKSRC} -name "intltool-merge.in" | ${XARGS} ${REINPLACE_CMD} -e \
's|mkdir $$lang or|mkdir $$lang, 0777 or| ; \
s|^push @INC, "/.*|push @INC, "${LOCALBASE}/share/intltool";|'
-intlhack_USE_GNOME_IMPL=intltool
-
-gtkhtml3_LIB_DEPENDS= gtkhtml-3.0.3:${PORTSDIR}/www/gtkhtml3
-gtkhtml3_DETECT= ${X11BASE}/libdata/pkgconfig/libgtkhtml-3.0.pc
-gtkhtml3_USE_GNOME_IMPL=gal2 gail
# End component definition section