aboutsummaryrefslogtreecommitdiffstats
path: root/Mk/bsd.gnome.mk
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2003-04-04 17:33:10 +0800
committermarcus <marcus@FreeBSD.org>2003-04-04 17:33:10 +0800
commitdb89b71c66eda7586dbcb2b617bf2cdaf00de094 (patch)
tree0936d7f42dc3fad1bd6e13a60af9fca710139f78 /Mk/bsd.gnome.mk
parent447573ef47802a36dd6f16ba7ea5df1e1247934a (diff)
downloadfreebsd-ports-gnome-db89b71c66eda7586dbcb2b617bf2cdaf00de094.tar.gz
freebsd-ports-gnome-db89b71c66eda7586dbcb2b617bf2cdaf00de094.tar.zst
freebsd-ports-gnome-db89b71c66eda7586dbcb2b617bf2cdaf00de094.zip
Fix a bug in detecting USE_GNOME components properly.
Diffstat (limited to 'Mk/bsd.gnome.mk')
-rw-r--r--Mk/bsd.gnome.mk3
1 files changed, 2 insertions, 1 deletions
diff --git a/Mk/bsd.gnome.mk b/Mk/bsd.gnome.mk
index 377cafbe9505..b4c9b283b7c6 100644
--- a/Mk/bsd.gnome.mk
+++ b/Mk/bsd.gnome.mk
@@ -486,7 +486,8 @@ _USE_GNOME+= ${${component}_USE_GNOME_IMPL} ${component}
# Then traverse through all components, check which of them
# exist in ${_USE_GNOME} and set variables accordingly
. for component in ${_USE_GNOME_ALL}
-. if ${_USE_GNOME:M${component}}==${component}
+_COMP_TEST= ${_USE_GNOME:M${component}}
+. if ${_COMP_TEST:S/${component}//}!=${_COMP_TEST:S/ / /g}
BUILD_DEPENDS+= ${${component}_BUILD_DEPENDS}
LIB_DEPENDS+= ${${component}_LIB_DEPENDS}
RUN_DEPENDS+= ${${component}_RUN_DEPENDS}