aboutsummaryrefslogtreecommitdiffstats
path: root/Mk/bsd.gnustep.mk
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2006-11-17 21:01:35 +0800
committerdinoex <dinoex@FreeBSD.org>2006-11-17 21:01:35 +0800
commit5ce71d19818e794a9d91c615915a932cb6d82287 (patch)
tree36d69aef7b1ad8072dec69420643b83206f57b7f /Mk/bsd.gnustep.mk
parent78206e39bf2f8945ba75775afe1477f3916c402f (diff)
downloadfreebsd-ports-gnome-5ce71d19818e794a9d91c615915a932cb6d82287.tar.gz
freebsd-ports-gnome-5ce71d19818e794a9d91c615915a932cb6d82287.tar.zst
freebsd-ports-gnome-5ce71d19818e794a9d91c615915a932cb6d82287.zip
- new option USE_GNUSTEP_LOCAL_BUNDLES
Diffstat (limited to 'Mk/bsd.gnustep.mk')
-rw-r--r--Mk/bsd.gnustep.mk13
1 files changed, 13 insertions, 0 deletions
diff --git a/Mk/bsd.gnustep.mk b/Mk/bsd.gnustep.mk
index 8f1c526835bb..a38f2c02fbaf 100644
--- a/Mk/bsd.gnustep.mk
+++ b/Mk/bsd.gnustep.mk
@@ -75,6 +75,9 @@
# USE_GNUSTEP_LOCAL_LIBS+= pantomime:mail/pantomime
# depends on a shared lib in Local directrory
#
+# USE_GNUSTEP_LOCAL_BUNDLES+= Cddb:audio/cddb-bundle
+# depends on Bundles installed in Local directrory at build and runtime
+#
# USE_GNUSTEP_SYSTEM_APPS+= ProjectCenter:devel/projectcenter.app
# depends on Application installed in System directrory at runtime
#
@@ -281,6 +284,16 @@ RUN_DEPENDS+= ${LOCALLIBDIR}/lib${_GNUSTEP_DEP:C/:.*//}.so:${PORTSDIR}/${_GNUSTE
.endif
# ---------------------------------------------------------------------------
+# source local bundles
+#
+.if defined(USE_GNUSTEP_LOCAL_BUNDLES)
+.for _GNUSTEP_DEP in ${USE_GNUSTEP_LOCAL_BUNDLES}
+BUILD_DEPENDS+= ${GNUSTEP_PREFIX}/Local/Library/Bundles/${_GNUSTEP_DEP:C/:.*//}.bundle/${_GNUSTEP_DEP:C/:.*//}:${PORTSDIR}/${_GNUSTEP_DEP:C/.*://}
+RUN_DEPENDS+= ${GNUSTEP_PREFIX}/Local/Library/Bundles/${_GNUSTEP_DEP:C/:.*//}.bundle/${_GNUSTEP_DEP:C/:.*//}:${PORTSDIR}/${_GNUSTEP_DEP:C/.*://}
+.endfor
+.endif
+
+# ---------------------------------------------------------------------------
# source system apps
#
.if defined(USE_GNUSTEP_SYSTEM_APPS)