aboutsummaryrefslogtreecommitdiffstats
path: root/Mk/bsd.options.mk
diff options
context:
space:
mode:
authorbdrewery <bdrewery@FreeBSD.org>2013-10-03 21:32:36 +0800
committerbdrewery <bdrewery@FreeBSD.org>2013-10-03 21:32:36 +0800
commit37bc2cf823c4c07e0c506dbf48834525decabb16 (patch)
tree9f64a6ddf0f19e87cb4131db9aecb5570c050e85 /Mk/bsd.options.mk
parentf7405aac37906b7b8d795bcabf62e5967479ada2 (diff)
downloadfreebsd-ports-gnome-37bc2cf823c4c07e0c506dbf48834525decabb16.tar.gz
freebsd-ports-gnome-37bc2cf823c4c07e0c506dbf48834525decabb16.tar.zst
freebsd-ports-gnome-37bc2cf823c4c07e0c506dbf48834525decabb16.zip
- Support {opt}_EXTRA_PATCHES
Reviewed by: bapt With hat: portmgr
Diffstat (limited to 'Mk/bsd.options.mk')
-rw-r--r--Mk/bsd.options.mk6
1 files changed, 6 insertions, 0 deletions
diff --git a/Mk/bsd.options.mk b/Mk/bsd.options.mk
index d8b74421084c..a2d4500c4413 100644
--- a/Mk/bsd.options.mk
+++ b/Mk/bsd.options.mk
@@ -93,6 +93,9 @@
# ${opt}_CMAKE_OFF When option is disabled, it will add its content to
# the CMAKE_ARGS.
#
+# ${opt}_EXTRA_PATCHES When option is enabled, it will add its content to
+# EXTRA_PATCHES
+#
# For each of CFLAGS CPPFLAGS CXXFLAGS LDFLAGS CONFIGURE_ENV MAKE_ARGS MAKE_ENV
# USES DISTFILES PLIST_FILES PLIST_DIRS PLIST_DIRSTRY, defining
# ${opt}_${variable} will add it to the actual variable when the option is enabled.
@@ -380,6 +383,9 @@ PLIST_SUB:= ${PLIST_SUB} ${opt}="@comment "
. endif
. if ${PORT_OPTIONS:M${opt}}
+. if defined(${opt}_EXTRA_PATCHES)
+EXTRA_PATCHES+= ${${opt}_EXTRA_PATCHES}
+. endif
. if defined(${opt}_CONFIGURE_ENABLE)
CONFIGURE_ARGS+= --enable-${${opt}_CONFIGURE_ENABLE}
. endif