aboutsummaryrefslogtreecommitdiffstats
path: root/Mk/bsd.options.mk
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2013-11-12 21:23:14 +0800
committermat <mat@FreeBSD.org>2013-11-12 21:23:14 +0800
commit2f008ebd7ec2e48cbe2b9edd7421ae19f71eadc8 (patch)
tree708d0b31da85eb388d3b06d1fa8abbf0c99e44da /Mk/bsd.options.mk
parentb0a97429451a1535de8955dfe38c24238449ff37 (diff)
downloadfreebsd-ports-gnome-2f008ebd7ec2e48cbe2b9edd7421ae19f71eadc8.tar.gz
freebsd-ports-gnome-2f008ebd7ec2e48cbe2b9edd7421ae19f71eadc8.tar.zst
freebsd-ports-gnome-2f008ebd7ec2e48cbe2b9edd7421ae19f71eadc8.zip
Allow multiple value in ${opt}_USE= FOO=bar,baz.
Which is nice in case you end up with something like : X11_USE= xorg=x11 xorg=ice xorg=sm xorg=xext xorg=xineramaproto xorg=xinerama xorg=xrandr xorg=xrender xorg=xtst now you can do : X11_USE= xorg=x11,ice,sm,xext,xineramaproto,xinerama,xrandr,xrender,xtst PR: ports/183892 Approved by: bapt
Diffstat (limited to 'Mk/bsd.options.mk')
-rw-r--r--Mk/bsd.options.mk4
1 files changed, 3 insertions, 1 deletions
diff --git a/Mk/bsd.options.mk b/Mk/bsd.options.mk
index 0a59e150050e..a70cf8fb7089 100644
--- a/Mk/bsd.options.mk
+++ b/Mk/bsd.options.mk
@@ -95,6 +95,8 @@
#
# ${opt}_USE= FOO=bar When option is enabled, it will enable
# USE_FOO+= bar
+# If you need more than one option, you can do
+# FOO=bar,baz and you'll get USE_FOO=bar baz
#
# For each of CFLAGS CPPFLAGS CXXFLAGS LDFLAGS CONFIGURE_ENV MAKE_ARGS MAKE_ENV
# ALL_TARGET INSTALL_TARGET USES DISTFILES PLIST_FILES PLIST_DIRS PLIST_DIRSTRY
@@ -383,7 +385,7 @@ PLIST_SUB:= ${PLIST_SUB} ${opt}="@comment "
. if defined(${opt}_USE)
. for option in ${${opt}_USE}
_u= ${option:C/=.*//g}
-USE_${_u:U}+= ${option:C/.*=//g}
+USE_${_u:U}+= ${option:C/.*=//g:C/,/ /g}
. endfor
. endif
. if defined(${opt}_CONFIGURE_ENABLE)