aboutsummaryrefslogtreecommitdiffstats
path: root/Mk/bsd.perl.mk
diff options
context:
space:
mode:
authorlinimon <linimon@FreeBSD.org>2007-09-25 07:05:56 +0800
committerlinimon <linimon@FreeBSD.org>2007-09-25 07:05:56 +0800
commit3763dfd3fe54b0350d1866b04b804a9d86caba8b (patch)
tree1e778b6f64465aef09308aee493fe2b8d8bab92c /Mk/bsd.perl.mk
parent183488f87caca300ba1dde96da888a017c490039 (diff)
downloadfreebsd-ports-gnome-3763dfd3fe54b0350d1866b04b804a9d86caba8b.tar.gz
freebsd-ports-gnome-3763dfd3fe54b0350d1866b04b804a9d86caba8b.tar.zst
freebsd-ports-gnome-3763dfd3fe54b0350d1866b04b804a9d86caba8b.zip
Disable AutoInstall from trying to contact CPAN directly in the case of
a missing dependency (which is the actual underlying error). This cures the case of the build cluster looping indefinitely asking for user input. Suggested by: tobez Regression-tested with: devel/p5-Config-Any
Diffstat (limited to 'Mk/bsd.perl.mk')
-rw-r--r--Mk/bsd.perl.mk4
1 files changed, 4 insertions, 0 deletions
diff --git a/Mk/bsd.perl.mk b/Mk/bsd.perl.mk
index 543d1088a00a..6319b24286d1 100644
--- a/Mk/bsd.perl.mk
+++ b/Mk/bsd.perl.mk
@@ -204,6 +204,10 @@ CONFIGURE_ARGS+= INSTALLDIRS="site"
.if defined(PERL_CONFIGURE)
USE_PERL5= yes
+# Disable AutoInstall from attempting to install from CPAN directly in
+# the case of missing dependencies. This causes the build to loop on
+# the build cluster asking for interactive input.
+CONFIGURE_ENV+= "PERL_EXTUTILS_AUTOINSTALL=--skipdeps"
.if defined(BATCH) && !defined(IS_INTERACTIVE)
CONFIGURE_ENV+= PERL_MM_USE_DEFAULT="YES"
.endif # defined(BATCH) && !defined(IS_INTERACTIVE)