aboutsummaryrefslogtreecommitdiffstats
path: root/Mk/bsd.php.mk
diff options
context:
space:
mode:
authorale <ale@FreeBSD.org>2006-05-06 21:26:49 +0800
committerale <ale@FreeBSD.org>2006-05-06 21:26:49 +0800
commitfa0ee9787d6279766d468c4a27040d8c3ec0af7e (patch)
treed567d1a145942f125ce6aa31265d4c973fe16556 /Mk/bsd.php.mk
parentd31a80e0f433ddb1e337f4e257ef88876b829db0 (diff)
downloadfreebsd-ports-gnome-fa0ee9787d6279766d468c4a27040d8c3ec0af7e.tar.gz
freebsd-ports-gnome-fa0ee9787d6279766d468c4a27040d8c3ec0af7e.tar.zst
freebsd-ports-gnome-fa0ee9787d6279766d468c4a27040d8c3ec0af7e.zip
Simplify PHP base ports infrastructure:
- remove all slave ports - add the ability to build all SAPIs concurrently - update php5 to 5.1.4 *Read* the UPDATING file *before* trying to update PHP (or at least before mailing me).
Diffstat (limited to 'Mk/bsd.php.mk')
-rw-r--r--Mk/bsd.php.mk46
1 files changed, 9 insertions, 37 deletions
diff --git a/Mk/bsd.php.mk b/Mk/bsd.php.mk
index cf7669e42188..a837e2459349 100644
--- a/Mk/bsd.php.mk
+++ b/Mk/bsd.php.mk
@@ -25,7 +25,6 @@
# WANT_PHP_CLI=yes - Want the CLI version of PHP.
# WANT_PHP_CGI=yes - Want the CGI version of PHP.
# WANT_PHP_MOD=yes - Want the Apache Module for PHP.
-# WANT_PHP_SCR=yes - Want the CLI or the CGI version of PHP.
# WANT_PHP_WEB=yes - Want the Apache Module or the CGI version of PHP.
#
# You may combine multiple WANT_PHP_* knobs.
@@ -86,63 +85,38 @@ check-makevars::
@${ECHO_CMD} "or WANT_PHP_MOD. Use only one of them."
@${FALSE}
. else
-. if defined(PHP_VERSION) && ${PHP_SAPI} == "cli"
+. if defined(PHP_VERSION) && ${PHP_SAPI:Mcgi} == "" && ${PHP_SAPI:Mmod} == ""
check-makevars::
@${ECHO_CMD} "This port requires the Apache Module or the CGI version of PHP, but you have"
- @${ECHO_CMD} "already installed a conflicting PHP port without them."
- @${FALSE}
-. endif
-. endif
-.else
-
-.if defined(WANT_PHP_SCR)
-. if defined(WANT_PHP_CGI) || defined(WANT_PHP_CLI)
-check-makevars::
- @${ECHO_CMD} "If you define WANT_PHP_SCR you cannot set also WANT_PHP_CGI"
- @${ECHO_CMD} "or WANT_PHP_CLI. Use only one of them."
- @${FALSE}
-. else
-. if defined(PHP_VERSION) && ${PHP_SAPI} == "mod"
-check-makevars::
- @${ECHO_CMD} "This port requires the CLI or the CGI version of PHP, but you have"
- @${ECHO_CMD} "already installed a conflicting PHP port without them."
+ @${ECHO_CMD} "already installed a PHP port without them."
@${FALSE}
. endif
. endif
.else
.if defined(WANT_PHP_CGI)
-. if defined(WANT_PHP_CLI) || defined(WANT_PHP_MOD)
-check-makevars::
- @${ECHO_CMD} "The CGI version of PHP avoids the installation of other SAPIs."
- @${ECHO_CMD} "Do not use WANT_PHP_CGI with other WANT_PHP_* knobs."
- @${FALSE}
-. else
-. if defined(PHP_VERSION) && ${PHP_SAPI} != "cgi"
+. if defined(PHP_VERSION) && ${PHP_SAPI:Mcgi} == ""
check-makevars::
@${ECHO_CMD} "This port requires the CGI version of PHP, but you have already"
- @${ECHO_CMD} "installed a conflicting PHP port without CGI."
+ @${ECHO_CMD} "installed a PHP port without CGI."
@${FALSE}
-. else
-PHP_PORT?= ${PORTSDIR}/www/php${PHP_VER}-cgi
-. endif
. endif
.else
.if defined(WANT_PHP_CLI)
-. if defined(PHP_VERSION) && ${PHP_SAPI} != "full" && ${PHP_SAPI} != "cli"
+. if defined(PHP_VERSION) && ${PHP_SAPI:Mcli} == ""
check-makevars::
@${ECHO_CMD} "This port requires the CLI version of PHP, but you have already"
- @${ECHO_CMD} "installed a conflicting PHP port without CLI."
+ @${ECHO_CMD} "installed a PHP port without CLI."
@${FALSE}
. endif
.else
.if defined(WANT_PHP_MOD)
-. if defined(PHP_VERSION) && (${PHP_SAPI} != "full" && ${PHP_SAPI} != "mod")
+. if defined(PHP_VERSION) && ${PHP_SAPI:Mmod} == ""
check-makevars::
@${ECHO_CMD} "This port requires the Apache Module for PHP, but you have already"
- @${ECHO_CMD} "installed a conflicting PHP port without the Apache Module."
+ @${ECHO_CMD} "installed a PHP port without the Apache Module."
@${FALSE}
. endif
.endif
@@ -153,9 +127,7 @@ check-makevars::
.endif
-.endif
-
-PHP_PORT?= ${PORTSDIR}/lang/php${PHP_VER}
+PHP_PORT= ${PORTSDIR}/lang/php${PHP_VER}
.if defined(USE_PHP_BUILD)
BUILD_DEPENDS+= ${LOCALBASE}/include/php/main/php.h:${PHP_PORT}