aboutsummaryrefslogtreecommitdiffstats
path: root/Mk/bsd.port.mk
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2004-01-24 00:22:26 +0800
committermarcus <marcus@FreeBSD.org>2004-01-24 00:22:26 +0800
commit030776be6e55e584205f124cb8bb1947fd340a6d (patch)
tree6d7c8d76ca98c7f3cfbc811ce51bdd571187aa99 /Mk/bsd.port.mk
parent574620fe75d3a248f51c98fd6dfb34f8e254386f (diff)
downloadfreebsd-ports-gnome-030776be6e55e584205f124cb8bb1947fd340a6d.tar.gz
freebsd-ports-gnome-030776be6e55e584205f124cb8bb1947fd340a6d.tar.zst
freebsd-ports-gnome-030776be6e55e584205f124cb8bb1947fd340a6d.zip
Fix a regression in bsd.port.mk where ports with multiple checksums per file
would fail make checksum. Note: this is the simplest fix, but there is a more complete fix by eik and myself that works in the spirit of the original distinfo cleanup patch. However, that patch needs to be tested on bento first. PR: 61772 Submitted by: dinoex
Diffstat (limited to 'Mk/bsd.port.mk')
-rw-r--r--Mk/bsd.port.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 17245a38bf26..1e272d1fa806 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -4116,7 +4116,7 @@ checksum: fetch
${ECHO_MSG} ">> Checksum for $$file is set to IGNORE in distinfo file even though"; \
${ECHO_MSG} " the file is not in the "'$$'"{IGNOREFILES} list."; \
OK="false"; \
- elif [ "$$CKSUM2" = "$$CKSUM" ]; then \
+ elif ${EXPR} "$$CKSUM2" : ".*$$CKSUM" > /dev/null; then \
${ECHO_MSG} ">> Checksum OK for $$file."; \
else \
${ECHO_MSG} ">> Checksum mismatch for $$file."; \