aboutsummaryrefslogtreecommitdiffstats
path: root/Mk/bsd.port.mk
diff options
context:
space:
mode:
authorkris <kris@FreeBSD.org>2007-08-08 11:46:04 +0800
committerkris <kris@FreeBSD.org>2007-08-08 11:46:04 +0800
commit0aed0939f4fd7f64eb185f1fad39d8ab09325fad (patch)
tree5a80fae520fd09a0374ef30d2f451db99a816a48 /Mk/bsd.port.mk
parent3dbc99ae3bae0d9a381d880afd4569f013158f17 (diff)
downloadfreebsd-ports-gnome-0aed0939f4fd7f64eb185f1fad39d8ab09325fad.tar.gz
freebsd-ports-gnome-0aed0939f4fd7f64eb185f1fad39d8ab09325fad.tar.zst
freebsd-ports-gnome-0aed0939f4fd7f64eb185f1fad39d8ab09325fad.zip
* Shuffle some important variable definitions to early in the file,
notably PORTSDIR. The previous commit introduced a use-before-define with respect to this variable, which broke things like portmaster. * Drop support for COMMENTFILE and a vestigial remnant of NetBSD support.
Diffstat (limited to 'Mk/bsd.port.mk')
-rw-r--r--Mk/bsd.port.mk22
1 files changed, 11 insertions, 11 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index c484a5f68663..7f5260ecf2d0 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -1089,6 +1089,17 @@ FreeBSD_MAINTAINER= portmgr@FreeBSD.org
# Most port authors should not need to understand anything after this point.
#
+# These need to be absolute since we don't know how deep in the ports
+# tree we are and thus can't go relative. They can, of course, be overridden
+# by individual Makefiles or local system make configuration.
+PORTSDIR?= /usr/ports
+LOCALBASE?= /usr/local
+X11BASE?= ${LOCALBASE}
+LINUXBASE?= /compat/linux
+DISTDIR?= ${PORTSDIR}/distfiles
+_DISTDIR?= ${DISTDIR}/${DIST_SUBDIR}
+INDEXDIR?= ${PORTSDIR}
+
.include "${PORTSDIR}/Mk/bsd.commands.mk"
#
@@ -1294,16 +1305,6 @@ PKGVERSION= ${PORTVERSION:C/[-_,]/./g}${_SUF1}${_SUF2}
PKGNAME= ${PKGNAMEPREFIX}${PORTNAME}${PKGNAMESUFFIX}-${PKGVERSION}
DISTNAME?= ${PORTNAME}-${DISTVERSIONPREFIX}${DISTVERSION:C/:(.)/\1/g}${DISTVERSIONSUFFIX}
-# These need to be absolute since we don't know how deep in the ports
-# tree we are and thus can't go relative. They can, of course, be overridden
-# by individual Makefiles or local system make configuration.
-PORTSDIR?= /usr/ports
-LOCALBASE?= /usr/local
-X11BASE?= ${LOCALBASE}
-LINUXBASE?= /compat/linux
-DISTDIR?= ${PORTSDIR}/distfiles
-_DISTDIR?= ${DISTDIR}/${DIST_SUBDIR}
-INDEXDIR?= ${PORTSDIR}
INDEXFILE?= INDEX-${OSVERSION:C/([0-9]).*/\1/}
DOCSDIR?= ${PREFIX}/share/doc/${PORTNAME}
@@ -2300,7 +2301,6 @@ COPYTREE_SHARE= ${SH} -c '(${FIND} -d $$0 $$2 | ${CPIO} -dumpl $$1 >/dev/null \
.undef NO_PACKAGE
.endif
-COMMENTFILE?= ${PKGDIR}/pkg-comment
DESCR?= ${PKGDIR}/pkg-descr
PLIST?= ${PKGDIR}/pkg-plist
PKGINSTALL?= ${PKGDIR}/pkg-install