aboutsummaryrefslogtreecommitdiffstats
path: root/Mk/bsd.port.mk
diff options
context:
space:
mode:
authoracm <acm@FreeBSD.org>2008-06-24 22:56:06 +0800
committeracm <acm@FreeBSD.org>2008-06-24 22:56:06 +0800
commit6a9c20fae4b0df89ee1b6212675d32d0124a3ce7 (patch)
tree6c71e4ed4ef94239b44d35ecb3656564535e32da /Mk/bsd.port.mk
parent9c0829ddd62f2d903e11c490fd791da000ccc04e (diff)
downloadfreebsd-ports-gnome-6a9c20fae4b0df89ee1b6212675d32d0124a3ce7.tar.gz
freebsd-ports-gnome-6a9c20fae4b0df89ee1b6212675d32d0124a3ce7.tar.zst
freebsd-ports-gnome-6a9c20fae4b0df89ee1b6212675d32d0124a3ce7.zip
- Add support for freepascal based ports
Approved by: portmgr (pav)
Diffstat (limited to 'Mk/bsd.port.mk')
-rw-r--r--Mk/bsd.port.mk7
1 files changed, 7 insertions, 0 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index d15ad3c33ba2..9a88b2db1010 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -423,6 +423,9 @@ FreeBSD_MAINTAINER= portmgr@FreeBSD.org
# USE_EFL - If set, this port use EFL libraries.
# Implies inclusion of bsd.efl.mk. (Also see
# that file for more information on USE_EFL_*).
+# USE_FPC - If set, this port relies on the Free Pascal language.
+# Implies inclusion of bsd.fpc.mk. (Also see
+# that file for more information on WANT_FPC_*).
# USE_JAVA - If set, this port relies on the Java language.
# Implies inclusion of bsd.java.mk. (Also see
# that file for more information on USE_JAVA_*).
@@ -1462,6 +1465,10 @@ PERL= ${LOCALBASE}/bin/perl
.include "${PORTSDIR}/Mk/bsd.efl.mk"
.endif
+.if defined(USE_FPC) || defined(WANT_FPC_BASE) || defined(WANT_FPC_ALL)
+.include "${PORTSDIR}/Mk/bsd.fpc.mk"
+.endif
+
.if defined(USE_JAVA)
.include "${PORTSDIR}/Mk/bsd.java.mk"
.endif