aboutsummaryrefslogtreecommitdiffstats
path: root/Mk/bsd.port.mk
diff options
context:
space:
mode:
authorasami <asami@FreeBSD.org>2000-11-16 21:06:29 +0800
committerasami <asami@FreeBSD.org>2000-11-16 21:06:29 +0800
commit97813f2e4b6086b07dddd1d7060ce9094fddfed3 (patch)
treef1976e7d678ba30bc7fc74dc0a206baeb478df04 /Mk/bsd.port.mk
parente241ea065727dff3bbede0b7e8b6ee4f8f757201 (diff)
downloadfreebsd-ports-gnome-97813f2e4b6086b07dddd1d7060ce9094fddfed3.tar.gz
freebsd-ports-gnome-97813f2e4b6086b07dddd1d7060ce9094fddfed3.tar.zst
freebsd-ports-gnome-97813f2e4b6086b07dddd1d7060ce9094fddfed3.zip
Add AUTO{CONF,MAKE}_{ENV,ARGS}. Among other things, this will fix
audio/libao, audio/libogg, audio/libvorbis and audio/vorbis-tools which need --add-missing to be passed to automake. PR: 22610 Submitted by: Theo van Klaveren <t.vanklaveren@student.utwente.nl>, roger, sobomax
Diffstat (limited to 'Mk/bsd.port.mk')
-rw-r--r--Mk/bsd.port.mk12
1 files changed, 10 insertions, 2 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 32664fc690ae..f632b6ba1e70 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -139,9 +139,15 @@ FreeBSD_MAINTAINER= asami@FreeBSD.org
# USE_AUTOMAKE - Says that the port uses automake. Implies USE_AUTOCONF.
# AUTOMAKE - Set to path of GNU automake if not in $PATH (default:
# automake).
+# AUTOMAKE_ARGS - Pass these args to automake if ${USE_AUTOMAKE} is set.
+# AUTOMAKE_ENV - Pass these env (shell-like) to automake if
+# ${USE_AUTOMAKE} is set.
# USE_AUTOCONF - Says that the port uses autoconf. Implies GNU_CONFIGURE.
# AUTOCONF - Set to path of GNU autoconf if not in $PATH (default:
# autoconf).
+# AUTOCONF_ARGS - Pass these args to autoconf if ${USE_AUTOCONF} is set.
+# AUTOCONF_ENV - Pass these env (shell-like) to autoconf if
+# ${USE_AUTOCONF} is set.
# USE_LIBTOOL - Says that the port uses Libtool. Implies GNU_CONFIGURE.
# LIBTOOL - Set to path of libtool (default: libtool).
# LIBTOOLFILES - Files to patch for libtool (defaults: "aclocal.m4" if
@@ -1755,10 +1761,12 @@ do-patch:
.if !target(do-configure)
do-configure:
.if defined(USE_AUTOMAKE)
- @(cd ${CONFIGURE_WRKSRC} && ${AUTOMAKE})
+ @(cd ${CONFIGURE_WRKSRC} && ${SETENV} ${AUTOMAKE_ENV} ${AUTOMAKE} \
+ ${AUTOMAKE_ARGS})
.endif
.if defined(USE_AUTOCONF)
- @(cd ${CONFIGURE_WRKSRC} && ${AUTOCONF})
+ @(cd ${CONFIGURE_WRKSRC} && ${SETENV} ${AUTOCONF_ENV} ${AUTOCONF} \
+ ${AUTOCONF_ARGS})
.endif
@if [ -f ${SCRIPTDIR}/configure ]; then \
cd ${.CURDIR} && ${SETENV} ${SCRIPTS_ENV} ${SH} \