aboutsummaryrefslogtreecommitdiffstats
path: root/Mk/bsd.port.mk
diff options
context:
space:
mode:
authorfjoe <fjoe@FreeBSD.org>2003-07-30 16:53:49 +0800
committerfjoe <fjoe@FreeBSD.org>2003-07-30 16:53:49 +0800
commit3702bf9a8038f68911889a704ff5e7023e167ab1 (patch)
treeb464280156eff8d7d56240a857fcec800afcc9af /Mk/bsd.port.mk
parentd7d84a64da817d08d233d7322d21c85688f88ffe (diff)
downloadfreebsd-ports-gnome-3702bf9a8038f68911889a704ff5e7023e167ab1.tar.gz
freebsd-ports-gnome-3702bf9a8038f68911889a704ff5e7023e167ab1.tar.zst
freebsd-ports-gnome-3702bf9a8038f68911889a704ff5e7023e167ab1.zip
Convert ${SU} to ${SU_CMD}. This allows to use sudo instead of su
by defining 'SU_CMD=/usr/local/bin/sudo sh -c'. Provide an example of using sudo instead of su as well. Approved by: kris, des
Diffstat (limited to 'Mk/bsd.port.mk')
-rw-r--r--Mk/bsd.port.mk5
1 files changed, 3 insertions, 2 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 06dd008ace08..0846d16c42da 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -795,7 +795,8 @@ SED?= /usr/bin/sed
SETENV?= /usr/bin/env
SH?= /bin/sh
STRIP_CMD?= /usr/bin/strip
-SU?= /usr/bin/su
+SU_CMD?= /usr/bin/su root -c
+#SU_CMD?= /usr/local/bin/sudo su -c
TAIL?= /usr/bin/tail
TEST?= test # Shell builtin
TR?= /usr/bin/tr
@@ -3258,7 +3259,7 @@ ${${target:U}_COOKIE}: ${_${target:U}_DEP} ${_${target:U}_SEQ}
.endif
@echo "===> Switching to root credentials for '${target}' target"
@cd ${.CURDIR} && \
- ${SU} root -c "${MAKE} ${__softMAKEFLAGS} ${_${target:U}_SUSEQ}"
+ ${SU_CMD} "${MAKE} ${__softMAKEFLAGS} ${_${target:U}_SUSEQ}"
@echo "===> Returning to user credentials"
@${TOUCH} ${TOUCH_FLAGS} ${.TARGET}
.elif defined(USE_SUBMAKE)