aboutsummaryrefslogtreecommitdiffstats
path: root/Mk/bsd.port.mk
diff options
context:
space:
mode:
authorasami <asami@FreeBSD.org>1997-06-24 15:16:21 +0800
committerasami <asami@FreeBSD.org>1997-06-24 15:16:21 +0800
commit7fc38acbfc4ca2c0a3fda0792aedd6334cb79612 (patch)
tree08df9cfc73f2ae5adf7aca82e61bca699f21f8cc /Mk/bsd.port.mk
parentacfa759c4e956e5152eefc43823db01a4d9fa633 (diff)
downloadfreebsd-ports-gnome-7fc38acbfc4ca2c0a3fda0792aedd6334cb79612.tar.gz
freebsd-ports-gnome-7fc38acbfc4ca2c0a3fda0792aedd6334cb79612.tar.zst
freebsd-ports-gnome-7fc38acbfc4ca2c0a3fda0792aedd6334cb79612.zip
Add new variable USE_PERL5. It is similar to USE_GMAKE, except that
it also sets RUN_DEPENDS (USE_GMAKE is BUILD_DEPENDS only). The (immediate) purpose of this is to avoid having to change 70 zillion ports when the version of perl changes. Also, when perl5 is pulled into -current, this will become a no-op in -current's bsd.port.mk. Reviewed by: jfitz
Diffstat (limited to 'Mk/bsd.port.mk')
-rw-r--r--Mk/bsd.port.mk9
1 files changed, 7 insertions, 2 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index af7bb33a3b62..dec44523d935 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -1,7 +1,7 @@
#-*- mode: Fundamental; tab-width: 4; -*-
# ex:ts=4
#
-# $Id: bsd.port.mk,v 1.258 1997/06/04 00:12:19 asami Exp $
+# $Id: bsd.port.mk,v 1.259 1997/06/18 03:20:22 asami Exp $
# $NetBSD: $
#
# bsd.port.mk - 940820 Jordan K. Hubbard.
@@ -120,6 +120,7 @@ OpenBSD_MAINTAINER= imp@OpenBSD.ORG
# BROKEN - Port is broken. Set this string to the reason why.
# RESTRICTED - Port is restricted. Set this string to the reason why.
# USE_GMAKE - Says that the port uses gmake.
+# USE_PERL5 - Says that the port uses perl5 for building and running.
# USE_IMAKE - Says that the port uses imake.
# USE_X11 - Says that the port uses X11 (i.e., installs in ${X11BASE}).
# NO_INSTALL_MANPAGES - For imake ports that don't like the install.man
@@ -303,7 +304,11 @@ BUILD_DEPENDS+= ${EXEC_DEPENDS}
RUN_DEPENDS+= ${EXEC_DEPENDS}
.endif
.if defined(USE_GMAKE)
-BUILD_DEPENDS+= gmake:${PORTSDIR}/devel/gmake
+BUILD_DEPENDS+= gmake:${PORTSDIR}/devel/gmake
+.endif
+.if defined(USE_PERL5)
+BUILD_DEPENDS+= perl5.004:${PORTSDIR}/lang/perl5
+RUN_DEPENDS+= perl5.004:${PORTSDIR}/lang/perl5
.endif
.if exists(${PORTSDIR}/../Makefile.inc)