aboutsummaryrefslogtreecommitdiffstats
path: root/Mk/bsd.port.mk
diff options
context:
space:
mode:
authorlinimon <linimon@FreeBSD.org>2007-09-14 06:10:33 +0800
committerlinimon <linimon@FreeBSD.org>2007-09-14 06:10:33 +0800
commit53d1c37149c1e2acf42f4b92b2d5a7cc9ac6e791 (patch)
treeff32ff4d26dbe2ea17d1cdd77e2dc852c9f1a77f /Mk/bsd.port.mk
parent1d879f034d2dee69ec14c53e674f78a3ad33c944 (diff)
downloadfreebsd-ports-gnome-53d1c37149c1e2acf42f4b92b2d5a7cc9ac6e791.tar.gz
freebsd-ports-gnome-53d1c37149c1e2acf42f4b92b2d5a7cc9ac6e791.tar.zst
freebsd-ports-gnome-53d1c37149c1e2acf42f4b92b2d5a7cc9ac6e791.zip
Restore the semantics of USE_PERL and friends by moving them back to
the 'post' block from which they originally came. This should fix the remaining few package build errors because of conditional perl inclusion. Pointy hat: linimon
Diffstat (limited to 'Mk/bsd.port.mk')
-rw-r--r--Mk/bsd.port.mk12
1 files changed, 7 insertions, 5 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index ab08c18fe18b..5d0020c1a2b8 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -1422,11 +1422,6 @@ SITE_PERL?= ${LOCALBASE}/${SITE_PERL_REL}
PERL5= ${LOCALBASE}/bin/perl${PERL_VERSION}
PERL= ${LOCALBASE}/bin/perl
-PLIST_SUB+= PERL_VERSION=${PERL_VERSION} \
- PERL_VER=${PERL_VER} \
- PERL_ARCH=${PERL_ARCH} \
- SITE_PERL=${SITE_PERL_REL}
-
.endif # !defined(_PERL_REFACTORING_COMPLETE)
.if defined(USE_LOCAL_MK)
@@ -1936,6 +1931,13 @@ RUN_DEPENDS+= ${_GL_${_component}_RUN_DEPENDS}
BUILD_DEPENDS+= bison:${PORTSDIR}/devel/bison
.endif
+.if !defined(_PERL_REFACTORING_COMPLETE)
+PLIST_SUB+= PERL_VERSION=${PERL_VERSION} \
+ PERL_VER=${PERL_VER} \
+ PERL_ARCH=${PERL_ARCH} \
+ SITE_PERL=${SITE_PERL_REL}
+.endif # !defined(_PERL_REFACTORING_COMPLETE)
+
.if defined(USE_LOCAL_MK)
.include "${PORTSDIR}/Mk/bsd.local.mk"
.endif