aboutsummaryrefslogtreecommitdiffstats
path: root/Mk/bsd.port.mk
diff options
context:
space:
mode:
authornetchild <netchild@FreeBSD.org>2006-05-02 18:06:54 +0800
committernetchild <netchild@FreeBSD.org>2006-05-02 18:06:54 +0800
commit5896db633e7426ed0a97e66872d90e8a15b7e26c (patch)
tree5fc679ae4f8f38324433c88de96ffed5a3d04963 /Mk/bsd.port.mk
parentb695508429bcc150ed434ded4fb64b2fe3bad6cd (diff)
downloadfreebsd-ports-gnome-5896db633e7426ed0a97e66872d90e8a15b7e26c.tar.gz
freebsd-ports-gnome-5896db633e7426ed0a97e66872d90e8a15b7e26c.tar.zst
freebsd-ports-gnome-5896db633e7426ed0a97e66872d90e8a15b7e26c.zip
Extract only the binary RPM's.
This should fix linux-expat, linux-glib2, linux-gnomelibs and linux-xorg-libs (and thus linux-jpeg) on pointyhat. Noticed by: pointyhat (kris)
Diffstat (limited to 'Mk/bsd.port.mk')
-rw-r--r--Mk/bsd.port.mk6
1 files changed, 5 insertions, 1 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index c8bee854975d..ddd0d389d4be 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -1831,7 +1831,7 @@ USE_SUBMAKE= yes
.if defined(USE_XLIB)
. if defined(USE_LINUX)
-RUN_DEPENDS+= ${LINUXBASE}/usr/X11R6/lib/libXrender.so.1:${PORTSDIR}/x11/linux-XFree86-libs
+RUN_DEPENDS+= ${LINUXBASE}/usr/X11R6/lib/libXrender.so.1:${PORTSDIR}/x11/linux-xorg-libs
. else
LIB_DEPENDS+= X11.6:${X_LIBRARIES_PORT}
. endif
@@ -1914,7 +1914,11 @@ MAKE_ENV+= PREFIX=${PREFIX} LOCALBASE=${LOCALBASE} X11BASE=${X11BASE} MOTIFLIB=
.if ${OSVERSION} < 500016
PTHREAD_CFLAGS?= -D_THREAD_SAFE
+. if ${CC} == "icc"
+PTHREAD_LIBS?= -mt
+. else
PTHREAD_LIBS?= -pthread
+. endif
.elif ${OSVERSION} < 502102
PTHREAD_CFLAGS?= -D_THREAD_SAFE
PTHREAD_LIBS?= -lc_r