aboutsummaryrefslogtreecommitdiffstats
path: root/Mk/bsd.port.mk
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2011-02-25 18:55:08 +0800
committerpav <pav@FreeBSD.org>2011-02-25 18:55:08 +0800
commitccda87eb707162fefab85768f233506d237d89c9 (patch)
tree5093e0e56b7be58747a2b7716911ebcf634cd1f4 /Mk/bsd.port.mk
parentaf2376386c475e2299695f431bbdd05184591f94 (diff)
downloadfreebsd-ports-gnome-ccda87eb707162fefab85768f233506d237d89c9.tar.gz
freebsd-ports-gnome-ccda87eb707162fefab85768f233506d237d89c9.tar.zst
freebsd-ports-gnome-ccda87eb707162fefab85768f233506d237d89c9.zip
- Remove NO_SIZE support
PR: ports/153547 Submitted by: Eitan Adler <lists@eitanadler.com>
Diffstat (limited to 'Mk/bsd.port.mk')
-rw-r--r--Mk/bsd.port.mk14
1 files changed, 2 insertions, 12 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 1499103d309b..1381e53997c0 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -871,14 +871,6 @@ FreeBSD_MAINTAINER= portmgr@FreeBSD.org
# change the owner and group of all files under ${WRKDIR}
# to 0:0. Set this variable if you want to turn off this
# feature.
-#
-# For makesum:
-#
-# NO_SIZE - Don't record size data in distinfo, needed
-# when the master site does not report file
-# sizes, or when multiple valid versions of
-# a distfile, having different sizes, exist.
-#
# For patch:
#
# EXTRA_PATCHES - Define this variable if you have patches not in
@@ -1229,7 +1221,7 @@ OSREL!= ${UNAME} -r | ${SED} -e 's/[-(].*//'
.if exists(/usr/include/sys/param.h)
OSVERSION!= ${AWK} '/^\#define[[:blank:]]__FreeBSD_version/ {print $$3}' < /usr/include/sys/param.h
.elif exists(/usr/src/sys/sys/param.h)
-OSVERSION!= ${AWK} '/^\#define[[:blank::]]__FreeBSD_version/ {print $$3}' < /usr/src/sys/sys/param.h
+OSVERSION!= ${AWK} '/^\#define[[:blank:]]__FreeBSD_version/ {print $$3}' < /usr/src/sys/sys/param.h
.else
OSVERSION!= ${SYSCTL} -n kern.osreldate
.endif
@@ -4930,9 +4922,7 @@ makesum: check-checksum-algorithms
$$alg_executable $$file >> ${DISTINFO_FILE}; \
fi; \
done; \
- if [ -z "${NO_SIZE}" ]; then \
- ${ECHO_CMD} "SIZE ($$file) = "`${LS} -ALln $$file | ${AWK} '{print $$5}'` >> ${DISTINFO_FILE}; \
- fi; \
+ ${ECHO_CMD} "SIZE ($$file) = "`${LS} -ALln $$file | ${AWK} '{print $$5}'` >> ${DISTINFO_FILE}; \
done \
)
@for file in ${_IGNOREFILES}; do \