aboutsummaryrefslogtreecommitdiffstats
path: root/Mk/bsd.port.mk
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2014-06-12 18:10:50 +0800
committerbapt <bapt@FreeBSD.org>2014-06-12 18:10:50 +0800
commit3dc67ec896f185eb71f9d79465b4773c4c35f0e9 (patch)
treecf9de94ec8b924516f1553ebd80116438426067c /Mk/bsd.port.mk
parent10f2dfc7e4f01f86785d2447a6cc7352e450f8c0 (diff)
downloadfreebsd-ports-gnome-3dc67ec896f185eb71f9d79465b4773c4c35f0e9.tar.gz
freebsd-ports-gnome-3dc67ec896f185eb71f9d79465b4773c4c35f0e9.tar.zst
freebsd-ports-gnome-3dc67ec896f185eb71f9d79465b4773c4c35f0e9.zip
Make pkg_install aware of @fc @fcfontsdir and @fontsdir
Simplify bsd.xorg.mk by only using those keywords run pkg_install.awk later to allow to use keywords in most of the targets in Mk/* Tested by: mandree
Diffstat (limited to 'Mk/bsd.port.mk')
-rw-r--r--Mk/bsd.port.mk8
1 files changed, 3 insertions, 5 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 3e588cfa29b8..5104b626e466 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -4202,6 +4202,9 @@ fix-plist-sequence: ${TMPPLIST}
@${MV} -f ${TMPGUCMD} ${TMPPLIST}
.endif
.if !defined(WITH_PKGNG)
+ @cd ${.CURDIR} && { ${MAKE} pretty-print-config | fold -sw 120 | ${SED} -e 's/^/@comment OPTIONS:/'; } >> ${TMPPLIST}
+ @${AWK} -f ${KEYWORDS}/pkg_install.awk ${TMPPLIST} > ${TMPPLIST}.keyword && \
+ ${MV} -f ${TMPPLIST}.keyword ${TMPPLIST}
@${ECHO_CMD} "@exec echo pkg_install EOL is scheduled for 2014-09-01. Please consider migrating to pkgng" >> ${TMPPLIST}
@${ECHO_CMD} "@exec echo http://blogs.freebsdish.org/portmgr/2014/02/03/time-to-bid-farewell-to-the-old-pkg_-tools/" >> ${TMPPLIST}
.endif
@@ -5627,11 +5630,6 @@ generate-plist:
.endif
.endif
.endif
-.if !defined(WITH_PKGNG)
- @cd ${.CURDIR} && { ${MAKE} pretty-print-config | fold -sw 120 | ${SED} -e 's/^/@comment OPTIONS:/'; } >> ${TMPPLIST}
- @${AWK} -f ${KEYWORDS}/pkg_install.awk ${TMPPLIST} > ${TMPPLIST}.keyword && \
- ${MV} -f ${TMPPLIST}.keyword ${TMPPLIST}
-.endif
.endif
${TMPPLIST}: