aboutsummaryrefslogtreecommitdiffstats
path: root/Mk/bsd.port.mk
diff options
context:
space:
mode:
authorantoine <antoine@FreeBSD.org>2013-11-29 16:39:03 +0800
committerantoine <antoine@FreeBSD.org>2013-11-29 16:39:03 +0800
commit61dde258e83808d563d795f85560ffa58f9f7eb3 (patch)
tree7bdc1009e2a26306cde7e718f4af4f439797053a /Mk/bsd.port.mk
parentc86a2afb95104e258c2598c7115c9acb723c7a7d (diff)
downloadfreebsd-ports-gnome-61dde258e83808d563d795f85560ffa58f9f7eb3.tar.gz
freebsd-ports-gnome-61dde258e83808d563d795f85560ffa58f9f7eb3.tar.zst
freebsd-ports-gnome-61dde258e83808d563d795f85560ffa58f9f7eb3.zip
Fix listing of info-* files when staging
Approved by: portmgr (bapt)
Diffstat (limited to 'Mk/bsd.port.mk')
-rw-r--r--Mk/bsd.port.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 9fdb56661184..0aa357b6c1d3 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -6009,12 +6009,12 @@ add-plist-info:
>> ${TMPPLIST}
@${ECHO_CMD} "@unexec [ \`info -d %D/${INFO_PATH} --output - 2>/dev/null | grep -c '^*'\` -eq 1 ] && rm -f %D/${INFO_PATH}/dir || :"\
>> ${TMPPLIST}
- @${LS} ${PREFIX}/${INFO_PATH}/$i.info* | ${SED} -e s:${PREFIX}/::g >> ${TMPPLIST}
+ @${LS} ${STAGEDIR}${PREFIX}/${INFO_PATH}/$i.info* | ${SED} -e s:${STAGEDIR}${PREFIX}/::g >> ${TMPPLIST}
@${ECHO_CMD} "@exec install-info --quiet %D/${INFO_PATH}/$i.info %D/${INFO_PATH}/dir" \
>> ${TMPPLIST}
.else
@${ECHO_CMD} "@info ${INFO_PATH}/$i.info" >> ${TMPPLIST}
- @${LS} ${PREFIX}/${INFO_PATH}/$i.info-* 2>/dev/null | ${SED} -e s:${PREFIX}/:@info\ :g >> ${TMPPLIST}
+ @${LS} ${STAGEDIR}${PREFIX}/${INFO_PATH}/$i.info-* 2>/dev/null | ${SED} -e s:${STAGEDIR}${PREFIX}/:@info\ :g >> ${TMPPLIST}
.endif
.endfor
.if defined(INFO_SUBDIR)