aboutsummaryrefslogtreecommitdiffstats
path: root/Mk/bsd.port.mk
diff options
context:
space:
mode:
authormva <mva@FreeBSD.org>2014-08-09 23:44:27 +0800
committermva <mva@FreeBSD.org>2014-08-09 23:44:27 +0800
commit628190fabfeb8c1639391774b2aea02d156ad50f (patch)
treeb3bd70d2aa9673b13c4a53db11582d39b1e33eb7 /Mk/bsd.port.mk
parentd13f7a4699c7aa3013c3d6bdbd8e5a158061646a (diff)
downloadfreebsd-ports-gnome-628190fabfeb8c1639391774b2aea02d156ad50f.tar.gz
freebsd-ports-gnome-628190fabfeb8c1639391774b2aea02d156ad50f.tar.zst
freebsd-ports-gnome-628190fabfeb8c1639391774b2aea02d156ad50f.zip
Convert the Python framework bits to USES=python.
Please use USES=python instead of USE_PYTHON. USE_PYTHON=yes becomes USES=python USE_PYTHON=2.7+ becomes USES=python:2.7+ USE_PYTHON_BUILD=3.3 becomes USES=python:3.3,build ... A new PYTHON_FEATURES variable was added, which enables certain features for a port and replaces some knobs at the same time; PYTHON_FEATURES=distutils replaces USE_PYDISTUTILS PYTHON_FEATURES=autoplist replaces PYDISTUTILS_AUTOPLIST PYTHON_FEATURES=py3kplist replaces PYTHON_PY3K_PLIST_HACK PYTHON_FEATURES=noegginfo replaces PYDISTUTILS_NOEGGINFO PYTHON_FEATURES=concurrent replaces PYTHON_CONCURRENT_INSTALL PYTHON_FEATURES=pythonprefix replaces USE_PYTHON_PREFIX Some knobs have been deprecated and are to be removed in the near future: PYTHON_MASTER_SITES - use MASTER_SITE_PYTHON instead PYTHON_PKGNAMESUFFIX - use PYTHON_PKGNAMEPREFIX instead PYDISTUTILS_INSTALLNOSINGLE - deprecated without replacement Some knobs have been removed completely: PYTHON_MASTER_SITE_SUBDIR PYTHON_DISTNAME PYTHON_WRKSRC Several variables specific to the Python framework are no longer passed to the build environment to avoid polluting dependency builds. PYTHON_VERSION is not passed to .MAKEFLAGS anymore PYTHON_DEFAULT_VERSION, PYTHON_DEFAULT_PORTVERSION and PYTHONBASE are not passed to the make environment anymore The conversion required a couple of ports to be updated to fit the changes and new requirements. Those included "bsd.python.mk" directly or contained checks in places, for which the USES framework would fail to provide correct values. Python modules directly using the upstream Python package (such as py-tkinter or py-sqlite3) were updated to avoid using the now unnecessary and remmoved knobs from "bsd.python.mk". Phabric: D399 exp-run: 167368 192357 PR: 167368 192357 Reviewed by: antoine, wg Exp-run award: antoine With hat: python@ Approved by: portmgr
Diffstat (limited to 'Mk/bsd.port.mk')
-rw-r--r--Mk/bsd.port.mk10
1 files changed, 1 insertions, 9 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 0e596f3d7f00..d864c928dfd7 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -394,10 +394,6 @@ FreeBSD_MAINTAINER= portmgr@FreeBSD.org
# USE_OCAML - If set, this port relies on the OCaml language.
# Implies inclusion of bsd.ocaml.mk. (Also see
# that file for more information on USE_OCAML*).
-# USE_PYTHON - If set, this port relies on the Python language.
-# Implies inclusion of bsd.python.mk. (Also see
-# that file for more information on USE_PYTHON_*
-# and USE_PYDISTUTILS).
# USE_RUBY - If set, this port relies on the Ruby language.
# Implies inclusion of bsd.ruby.mk. (Also see
# that file for more information on USE_RUBY_*).
@@ -1444,7 +1440,7 @@ PKGCOMPATDIR?= ${LOCALBASE}/lib/compat/pkg
.endif
.if defined(USE_PYTHON) || defined(USE_PYTHON_BUILD) || defined(USE_PYTHON_RUN)
-.include "${PORTSDIR}/Mk/bsd.python.mk"
+USES+= python
.endif
.if defined(USE_EFL) || defined(WANT_EFL) || defined(USE_EFL_ESMART)
@@ -1890,10 +1886,6 @@ IGNORE= Do not define STAGEDIR in command line
.include "${PORTSDIR}/Mk/bsd.php.mk"
.endif
-.if defined(USE_PYTHON)
-.include "${PORTSDIR}/Mk/bsd.python.mk"
-.endif
-
.if defined(USE_WX) || defined(USE_WX_NOT)
.include "${PORTSDIR}/Mk/bsd.wx.mk"
.endif