aboutsummaryrefslogtreecommitdiffstats
path: root/Mk/bsd.port.mk
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2013-10-09 23:11:32 +0800
committerbapt <bapt@FreeBSD.org>2013-10-09 23:11:32 +0800
commitb4980cacd67eed419935f4262cd287dc62b6ee55 (patch)
tree2b308aa81f8f91513d04cb0cf319755b7d03e8bd /Mk/bsd.port.mk
parented3a09a7a81b2143728245d08cf22cbd43c6f89f (diff)
downloadfreebsd-ports-gnome-b4980cacd67eed419935f4262cd287dc62b6ee55.tar.gz
freebsd-ports-gnome-b4980cacd67eed419935f4262cd287dc62b6ee55.tar.zst
freebsd-ports-gnome-b4980cacd67eed419935f4262cd287dc62b6ee55.zip
First set of Q/A for staged ports.
A couple of Q/A tests are done if the DEVELOPER macros is set in make.conf Right now the tests are: - Check if the symlinks are properly created - Check if the binaries are stripped (just warn) - Check if the STAGEDIR or the WORKDIR are referenced in the final files - Check if the ports provide script with bad shebangs.
Diffstat (limited to 'Mk/bsd.port.mk')
-rw-r--r--Mk/bsd.port.mk7
1 files changed, 7 insertions, 0 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 73506d5ccb59..87eb92d263a1 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -1129,6 +1129,7 @@ _DISTDIR?= ${DISTDIR}/${DIST_SUBDIR}
INDEXDIR?= ${PORTSDIR}
SRC_BASE?= /usr/src
USESDIR?= ${PORTSDIR}/Mk/Uses
+SCRIPTSDIR?= ${PORTSDIR}/Mk/Scripts
LIB_DIRS?= /lib /usr/lib ${LOCALBASE}/lib
.if defined(FORCE_STAGE)
@@ -4341,11 +4342,17 @@ _STAGE_SUSEQ= create-users-groups do-install post-install post-stage compress-ma
install-rc-script install-ldconfig-file install-license \
install-desktop-entries add-plist-info add-plist-docs add-plist-examples \
add-plist-data add-plist-post fix-plist-sequence
+.if defined(DEVELOPER)
+_STAGE_SUSEQ+= stage-qa
+.endif
.else
_STAGE_SEQ+= create-users-groups do-install post-install post-stage compress-man \
install-rc-script install-ldconfig-file install-license \
install-desktop-entries add-plist-info add-plist-docs add-plist-examples \
add-plist-data add-plist-post fix-plist-sequence
+.if defined(DEVELOPER)
+_STAGE_SEQ+= stage-qa
+.endif
.endif
.if defined(WITH_PKGNG)
_INSTALL_DEP= stage