aboutsummaryrefslogtreecommitdiffstats
path: root/Mk/bsd.port.mk
diff options
context:
space:
mode:
authorasami <asami@FreeBSD.org>2001-02-17 08:46:26 +0800
committerasami <asami@FreeBSD.org>2001-02-17 08:46:26 +0800
commit5dec7fc8c6428f3559736b32c2dfe1280c3da282 (patch)
treeef626916204c1e914a377012db104d57578ce9c8 /Mk/bsd.port.mk
parentd9b8eff19fba32cf59cf420b984913df64e57e8b (diff)
downloadfreebsd-ports-gnome-5dec7fc8c6428f3559736b32c2dfe1280c3da282.tar.gz
freebsd-ports-gnome-5dec7fc8c6428f3559736b32c2dfe1280c3da282.tar.zst
freebsd-ports-gnome-5dec7fc8c6428f3559736b32c2dfe1280c3da282.zip
(1) Change USE_NEWGCC dependency from lang/egcs to lang/gcc295.
Submitted by: reg PR: 24525 Approved by: obrien (2) Change XFree86 version in PKG_IGNORE_DEPENDS Submitted by: olgeni (3) Change message for "old layout" error to include a pointer to the cvsup FAQ. Submitted by: kris
Diffstat (limited to 'Mk/bsd.port.mk')
-rw-r--r--Mk/bsd.port.mk6
1 files changed, 3 insertions, 3 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 9dafe6c72f5f..943a09d3d34a 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -624,7 +624,7 @@ TEMPLATES?= ${PORTSDIR}/Templates
(!defined(PKGDIR) && exists(${MASTERDIR}/pkg)) || \
(!defined(MD5_FILE) && exists(${MASTERDIR}/files/md5))
pre-everything::
- @${ECHO} "Error: your port uses an old layout. Please update it to match this bsd.port.mk."
+ @${ECHO} "Error: your port uses an old layout. Please update it to match this bsd.port.mk. If you have updated your ports collection via cvsup and are still getting this error, see Q12 and Q13 in the cvsup FAQ on http://www.polstra.com for further information."
@${FALSE}
.endif
PATCHDIR?= ${MASTERDIR}/files
@@ -806,7 +806,7 @@ LIBTOOLFLAGS?= --disable-ltlibs
.if defined(USE_NEWGCC) && ${OSVERSION} < 400012
CC= gcc295
CXX= g++295
-BUILD_DEPENDS+= gcc295:${PORTSDIR}/lang/egcs
+BUILD_DEPENDS+= gcc295:${PORTSDIR}/lang/gcc295
MAKE_ENV+= CC=${CC} CXX=${CXX}
.endif
@@ -836,7 +836,7 @@ LIB_DEPENDS+= dps.0:${PORTSDIR}/x11/dgs
LIB_DEPENDS+= GL.14:${PORTSDIR}/graphics/Mesa3
.endif
XAWVER= 6
-PKG_IGNORE_DEPENDS?= '(XFree86-3\.3\.6_4)'
+PKG_IGNORE_DEPENDS?= '(XFree86-3\.3\.6_7)'
.else
.if defined(USE_IMAKE)
BUILD_DEPENDS+= imake:${PORTSDIR}/devel/imake-4