aboutsummaryrefslogtreecommitdiffstats
path: root/Mk/bsd.port.mk
diff options
context:
space:
mode:
authorkris <kris@FreeBSD.org>2003-02-17 05:22:15 +0800
committerkris <kris@FreeBSD.org>2003-02-17 05:22:15 +0800
commit5f240fd9d3290717b1eb15db053e535312f5234b (patch)
tree99d66e275a2b62401194ceeb2a18753e87c521b6 /Mk/bsd.port.mk
parent7ad83079d6e0527cc38a7cf3ccf7affc0862a350 (diff)
downloadfreebsd-ports-gnome-5f240fd9d3290717b1eb15db053e535312f5234b.tar.gz
freebsd-ports-gnome-5f240fd9d3290717b1eb15db053e535312f5234b.tar.zst
freebsd-ports-gnome-5f240fd9d3290717b1eb15db053e535312f5234b.zip
Update the description of the various "do not build this port" variables
(RESTRICTED, NO_PACKAGE, NO_CDROM, BROKEN) to match current reality. Add documentation of the FORBIDDEN and IGNORE variables. Garbage collect the commented-out FORBIDDEN string for the openssl ports since we no longer need to forbid crypto software.
Diffstat (limited to 'Mk/bsd.port.mk')
-rw-r--r--Mk/bsd.port.mk24
1 files changed, 17 insertions, 7 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 51aef29a693f..f1a5395eeddd 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -100,12 +100,24 @@ FreeBSD_MAINTAINER= portmgr@FreeBSD.org
# These are string variables; you should set them to the reason why
# they are necessary.
#
-# RESTRICTED - Port is restricted (e.g., contains cryptography, etc.).
-# NO_CDROM - Port may not go on CDROM.
-# NO_PACKAGE - Port should not be packaged but distfiles can be put on
-# ftp sites and CDROMs.
+# RESTRICTED - Prevent the distribution of distfiles and packages to
+# the FTP sites or on CDROM (e.g. forbidden by license
+# considerations).
+# NO_CDROM - Packages and distfiles may not go on CDROM (e.g. must
+# not be re-sold) but can go on FTP sites.
+# NO_PACKAGE - Port should not be packaged for ftp sites or CDROMs,
+# but distfiles can be put on ftp sites and CDROMs.
+# FORBIDDEN - Package build should not be attempted because of
+# security vulnerabilities.
+# IGNORE - Package build should be skipped entirely (e.g.
+# because of serious unfixable problems in the build,
+# because it cannot be manually fetched, etc). Error
+# logs will not appear on bento, so this should be
+# used sparingly.
# BROKEN_ELF - Port doesn't build on ELF machines.
-# BROKEN - Port is broken.
+# BROKEN - Port is believed to be broken. Package builds will
+# still be attempted on the bento package cluster to
+# test this assumption.
#
# In addition to RESTRICTED or NO_CDROM, if only a subset of distfiles
# or patchfiles have redistribution restrictions, set the following
@@ -833,8 +845,6 @@ OPENSSLLIB= ${OPENSSLBASE}/lib
OPENSSLINC= ${OPENSSLBASE}/include
MAKE_ENV+= OPENSSLLIB=${OPENSSLLIB} OPENSSLINC=${OPENSSLINC} \
OPENSSLBASE=${OPENSSLBASE} OPENSSLDIR=${OPENSSLDIR}
-### crypto
-#RESTRICTED= "Contains cryptography."
.endif
.if defined(EMACS_PORT_NAME)