aboutsummaryrefslogtreecommitdiffstats
path: root/Mk/bsd.port.mk
diff options
context:
space:
mode:
authorasami <asami@FreeBSD.org>2000-04-10 20:31:02 +0800
committerasami <asami@FreeBSD.org>2000-04-10 20:31:02 +0800
commit599191f91e9df51285f4f08da36c5cdcfaf90241 (patch)
tree537f733871840a7776eb3fd42a352297bcd99e2b /Mk/bsd.port.mk
parent3e2703c7fdf07220193f0b26626f3a8383a53ed7 (diff)
downloadfreebsd-ports-gnome-599191f91e9df51285f4f08da36c5cdcfaf90241.tar.gz
freebsd-ports-gnome-599191f91e9df51285f4f08da36c5cdcfaf90241.tar.zst
freebsd-ports-gnome-599191f91e9df51285f4f08da36c5cdcfaf90241.zip
Add PKGNAMEPREFIX and PKGNAMESUFFIX - these are to be used in case the
package name includes "language specifics" or "compilation options" as specified in the handbook. PKGNAME is now defined as ${PKGNAMEPREFIX}${PORTNAME}${PKGNAMESUFFIX}-${PORTVERSION}. Suggested by: mharo (prefix), reg (suffix) Reviewed by: the ports list
Diffstat (limited to 'Mk/bsd.port.mk')
-rw-r--r--Mk/bsd.port.mk11
1 files changed, 7 insertions, 4 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 24337731b686..7c8ee50a7bd4 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -43,8 +43,11 @@ FreeBSD_MAINTAINER= asami@FreeBSD.org
#
# PORTNAME - Name of software.
# PORTVERSION - Version of software.
-# PKGNAME - Always defined as ${PORTNAME}-${PORTVERSION}. Do not
-# define this in your Makefile.
+# PKGNAMEPREFIX - Prefix to specify that port is language-specific, etc.
+# PKGNAMESUFFIX - Suffix to specify compilation options.
+# PKGNAME - Always defined as
+# ${PKGNAMEPREFIX}${PORTNAME}${PKGNAMESUFFIX}-${PORTVERSION}.
+# Do not define this in your Makefile.
# DISTNAME - Name of port or distribution used in generating
# WRKSRC and DISTFILES below (default:
# ${PORTNAME}-${PORTVERSION}).
@@ -1113,8 +1116,8 @@ FETCH_BEFORE_ARGS+= -l
@${ECHO} "${PKGNAME}: You need to define PORTNAME and PORTVERSION instead of PKGNAME."
@${FALSE}
.endif
-PKGNAME= ${PORTNAME}-${PORTVERSION}
-DISTNAME?= ${PKGNAME}
+PKGNAME= ${PKGNAMEPREFIX}${PORTNAME}${PKGNAMESUFFIX}-${PORTVERSION}
+DISTNAME?= ${PORTNAME}-${PORTVERSION}
.else
# old style
PKGNAME?= ${DISTNAME}