aboutsummaryrefslogtreecommitdiffstats
path: root/Mk/bsd.port.mk
diff options
context:
space:
mode:
authorobrien <obrien@FreeBSD.org>2001-10-29 09:42:08 +0800
committerobrien <obrien@FreeBSD.org>2001-10-29 09:42:08 +0800
commitfbbb05e4beff53091339a38c287f22e3c50264aa (patch)
treed94cac279722593f67b89e3d384b5d9f92cdba08 /Mk/bsd.port.mk
parent90331b58be5b078bfe9d8cf133b30df7386f01c9 (diff)
downloadfreebsd-ports-gnome-fbbb05e4beff53091339a38c287f22e3c50264aa.tar.gz
freebsd-ports-gnome-fbbb05e4beff53091339a38c287f22e3c50264aa.tar.zst
freebsd-ports-gnome-fbbb05e4beff53091339a38c287f22e3c50264aa.zip
USE_AUTOCONF and USE_AUTOMAKE now depend and use the legacy versions.
This is the fastest way to move forward. A better way would be to set USE_AUTOCONF and USE_AUTOMAKE to the version desired. We can do that later, I don't want to hold up the update of the autoconf and automake ports the latest versions.
Diffstat (limited to 'Mk/bsd.port.mk')
-rw-r--r--Mk/bsd.port.mk8
1 files changed, 4 insertions, 4 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 361d5394a167..0cab56529871 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -793,11 +793,11 @@ CONFIGURE_ENV+= MAKE=${GMAKE}
.endif
.if defined(USE_AUTOMAKE)
USE_AUTOCONF= yes
-BUILD_DEPENDS+= automake:${PORTSDIR}/devel/automake
+BUILD_DEPENDS+= ${AUTOMAKE}:${PORTSDIR}/devel/${AUTOMAKE}
.endif
.if defined(USE_AUTOCONF)
GNU_CONFIGURE= yes
-BUILD_DEPENDS+= autoconf:${PORTSDIR}/devel/autoconf
+BUILD_DEPENDS+= ${AUTOCONF}:${PORTSDIR}/devel/${AUTOCONF}
.endif
.if defined(USE_LIBTOOL)
GNU_CONFIGURE= yes
@@ -941,8 +941,8 @@ NONEXISTENT?= /nonexistent
# Miscellaneous overridable commands:
GMAKE?= gmake
-AUTOMAKE?= automake
-AUTOCONF?= autoconf
+AUTOMAKE?= automake14
+AUTOCONF?= autoconf213
LIBTOOL?= libtool
XMKMF?= xmkmf -a
.if exists(/sbin/md5)