aboutsummaryrefslogtreecommitdiffstats
path: root/Mk/bsd.port.mk
diff options
context:
space:
mode:
authorobrien <obrien@FreeBSD.org>2001-09-29 00:45:15 +0800
committerobrien <obrien@FreeBSD.org>2001-09-29 00:45:15 +0800
commit410c9fdb699b81f3382505e8f4de5a67a624bcd7 (patch)
tree63e6a7caa28afefd23bc2c985fb101126aec4b45 /Mk/bsd.port.mk
parent7221e85d52662217f5c2c452cdf30494e6d4ad06 (diff)
downloadfreebsd-ports-gnome-410c9fdb699b81f3382505e8f4de5a67a624bcd7.tar.gz
freebsd-ports-gnome-410c9fdb699b81f3382505e8f4de5a67a624bcd7.tar.zst
freebsd-ports-gnome-410c9fdb699b81f3382505e8f4de5a67a624bcd7.zip
Add a "LATEST_LINK" knob. This makes it easy to set the Latest link, so that
less ports have to use NO_LATEST_LINK, and we won't have to keep artificially setting the PORTNAME to get the Latest link logic to do something reasonable. Approved by: will
Diffstat (limited to 'Mk/bsd.port.mk')
-rw-r--r--Mk/bsd.port.mk5
1 files changed, 4 insertions, 1 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index d003b1d4b67d..dd4cfd440097 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -457,6 +457,8 @@ FreeBSD_MAINTAINER= portmgr@FreeBSD.org
# NO_LATEST_LINK - Do not install the "Latest" link for package. Define this
# if this port is a beta version of another stable port
# which is also in the tree.
+# LATEST_LINK - Install the "Latest" link for the package as ___. Define
+# this if the "Latest" link name will be incorrectly determined.
#
# This is used in all stages:
#
@@ -1265,7 +1267,8 @@ PKGFILE?= ${.CURDIR}/${PKGNAME}${PKG_SUFX}
# The "latest version" link -- ${PKGNAME} minus everthing after the last '-'
PKGLATESTREPOSITORY?= ${PACKAGES}/Latest
PKGBASE?= ${PKGNAMEPREFIX}${PORTNAME}${PKGNAMESUFFIX}
-PKGLATESTFILE?= ${PKGLATESTREPOSITORY}/${PKGBASE}${PKG_SUFX}
+LATEST_LINK?= ${PKGBASE}
+PKGLATESTFILE= ${PKGLATESTREPOSITORY}/${LATEST_LINK}${PKG_SUFX}
.if defined(PERL_CONFIGURE)
CONFIGURE_ARGS+= CC="${CC}" CCFLAGS="${CFLAGS}" PREFIX="${PREFIX}"