aboutsummaryrefslogtreecommitdiffstats
path: root/Mk/bsd.port.mk
diff options
context:
space:
mode:
authorjkh <jkh@FreeBSD.org>1994-09-09 08:17:47 +0800
committerjkh <jkh@FreeBSD.org>1994-09-09 08:17:47 +0800
commit5a1620d1426cf8d1aabe8700de2bdebaeb7059d0 (patch)
treeea420ccdcaf7c77f8b52a9d1435a4c4de2866609 /Mk/bsd.port.mk
parent9827f43921bf7e6f0afa093066987dc7af5996dd (diff)
downloadfreebsd-ports-gnome-5a1620d1426cf8d1aabe8700de2bdebaeb7059d0.tar.gz
freebsd-ports-gnome-5a1620d1426cf8d1aabe8700de2bdebaeb7059d0.tar.zst
freebsd-ports-gnome-5a1620d1426cf8d1aabe8700de2bdebaeb7059d0.zip
As per suggestion by Michael Reifenberger, make ncftp use the -N flag.
Reviewed by: jkh Submitted by: mr
Diffstat (limited to 'Mk/bsd.port.mk')
-rw-r--r--Mk/bsd.port.mk5
1 files changed, 3 insertions, 2 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 01861916153c..5f159350bc33 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -1,7 +1,7 @@
# bsd.port.mk - 940820 Jordan K. Hubbard.
# This file is in the public domain.
#
-# $Id: bsd.port.mk,v 1.26 1994/09/02 01:32:13 jkh Exp $
+# $Id: bsd.port.mk,v 1.27 1994/09/02 01:53:33 jkh Exp $
#
# Supported Variables and their behaviors:
@@ -62,6 +62,7 @@
GMAKE?= gmake
NCFTP?= /usr/local/bin/ncftp
+NCFTPFLAGS?= -N
# These need to be absolute since we don't know how deep in the ports
# tree we are and thus can't go relative. They can, of course, be overridden
@@ -289,7 +290,7 @@ ${EXTRACT_COOKIE}:
mkdir -p `dirname ${DISTFILE}`; \
fi; \
if cd `dirname ${DISTFILE}`; then \
- if ${NCFTP} ${HOME_LOCATION}; then \
+ if ${NCFTP} ${NCFTPFLAGS} ${HOME_LOCATION}; then \
${EXTRACT_CMD} ${EXTRACT_ARGS} ${DISTFILE}; \
else \
echo ">> Couldn't fetch it - please retreive ${DISTFILE} manually and try again."; \