aboutsummaryrefslogtreecommitdiffstats
path: root/Mk/bsd.port.options.mk
diff options
context:
space:
mode:
authorlinimon <linimon@FreeBSD.org>2006-10-01 03:23:40 +0800
committerlinimon <linimon@FreeBSD.org>2006-10-01 03:23:40 +0800
commit6352ee8411d5bb86705c62e877feb428d655aead (patch)
treebad4bb9582fe80df4bd25281ab9b7b4c72623853 /Mk/bsd.port.options.mk
parent28338c00c5191fd8d145d13d5ad1039126716f43 (diff)
downloadfreebsd-ports-gnome-6352ee8411d5bb86705c62e877feb428d655aead.tar.gz
freebsd-ports-gnome-6352ee8411d5bb86705c62e877feb428d655aead.tar.zst
freebsd-ports-gnome-6352ee8411d5bb86705c62e877feb428d655aead.zip
Split the bsd.port.pre.mk functionality into two pieces. The majority is
left unchanged but the processing of dependencies is moved after OPTIONS processing. See comments for suggested usage. This functionality is still experimental and not yet used by any port.
Diffstat (limited to 'Mk/bsd.port.options.mk')
-rw-r--r--Mk/bsd.port.options.mk26
1 files changed, 26 insertions, 0 deletions
diff --git a/Mk/bsd.port.options.mk b/Mk/bsd.port.options.mk
new file mode 100644
index 000000000000..d36f9cd142c2
--- /dev/null
+++ b/Mk/bsd.port.options.mk
@@ -0,0 +1,26 @@
+#-*- mode: Fundamental; tab-width: 4; -*-
+# ex:ts=4
+#
+# bsd.port.options.mk - Allow OPTIONS to determine dependencies
+#
+# usage:
+#
+# .include "bsd.port.pre.mk"
+# <deal with user options>
+# .include "bsd.port.options.mk"
+# <other work, including adjusting dependencies>
+# .include "bsd.port.post.mk"
+#
+# Created by: Shaun Amott <shaun@inerd.com>
+#
+# $FreeBSD$
+#
+
+OPTIONS_Include_MAINTAINER= portmgr@FreeBSD.org
+
+USEOPTIONSMK= yes
+INOPTIONSMK= yes
+
+.include "bsd.port.mk"
+
+.undef INOPTIONSMK