aboutsummaryrefslogtreecommitdiffstats
path: root/Mk/bsd.port.subdir.mk
diff options
context:
space:
mode:
authorwill <will@FreeBSD.org>2001-12-23 19:11:40 +0800
committerwill <will@FreeBSD.org>2001-12-23 19:11:40 +0800
commit13f3df279ab6950ef05b117081dd8440732429f9 (patch)
tree277ffd22993565fdc8f8eb5c901c99ddfa0fbc7d /Mk/bsd.port.subdir.mk
parent28713e9c207f40a075b3ce4cebb133c66d1d366e (diff)
downloadfreebsd-ports-gnome-13f3df279ab6950ef05b117081dd8440732429f9.tar.gz
freebsd-ports-gnome-13f3df279ab6950ef05b117081dd8440732429f9.tar.zst
freebsd-ports-gnome-13f3df279ab6950ef05b117081dd8440732429f9.zip
Don't descend into a subdir for 'readmes' target if subdir doesn't exist.
PR: 28510 Submitted by: Philippe Casidy <pcasidy@casidy.com>
Diffstat (limited to 'Mk/bsd.port.subdir.mk')
-rw-r--r--Mk/bsd.port.subdir.mk2
1 files changed, 2 insertions, 0 deletions
diff --git a/Mk/bsd.port.subdir.mk b/Mk/bsd.port.subdir.mk
index 5a6511c54f6f..61cdec288761 100644
--- a/Mk/bsd.port.subdir.mk
+++ b/Mk/bsd.port.subdir.mk
@@ -207,12 +207,14 @@ README.html:
@echo "===> Creating README.html"
@> $@.tmp
.for entry in ${SUBDIR}
+.if exists(${entry})
.if defined(PORTSTOP)
@echo -n '<a href="'${entry}/README.html'">'"`echo ${entry} | ${HTMLIFY}`"'</a>: ' >> $@.tmp
.else
@echo -n '<a href="'${entry}/README.html'">'"`cd ${entry}; make package-name | ${HTMLIFY}`</a>: " >> $@.tmp
.endif
@cat `cd ${entry}; make -V COMMENT` | ${HTMLIFY} >> $@.tmp
+.endif
.endfor
@sort -t '>' +1 -2 $@.tmp > $@.tmp2
.if exists(${DESCR})