aboutsummaryrefslogtreecommitdiffstats
path: root/Mk/bsd.port.subdir.mk
diff options
context:
space:
mode:
authorlinimon <linimon@FreeBSD.org>2006-01-24 07:54:22 +0800
committerlinimon <linimon@FreeBSD.org>2006-01-24 07:54:22 +0800
commit0a183b8dcaff16ef1ecf1ee29dde95c5034b0dbf (patch)
treed1bbe14afb9ff5f95d158a69ec6558d27bb76938 /Mk/bsd.port.subdir.mk
parent0667fd1681f3d36a2b81d7993b5c3c694191524e (diff)
downloadfreebsd-ports-gnome-0a183b8dcaff16ef1ecf1ee29dde95c5034b0dbf.tar.gz
freebsd-ports-gnome-0a183b8dcaff16ef1ecf1ee29dde95c5034b0dbf.tar.zst
freebsd-ports-gnome-0a183b8dcaff16ef1ecf1ee29dde95c5034b0dbf.zip
Fix 'make search' on 4.X. Has no effect on 5.X and 6.X which worked
correctly to start with. NOTE: if you have your ports tree outside of /usr/ports and don't make your own INDEX, 'make search' will return no results. This was a pre-existing problem which no one had ever noticed. People with long experience in software can imagine the merriment of attempting to debug the current problem given this, for themselves. PR: ports/92189 Submitted by: linimon Fix from clement
Diffstat (limited to 'Mk/bsd.port.subdir.mk')
-rw-r--r--Mk/bsd.port.subdir.mk14
1 files changed, 9 insertions, 5 deletions
diff --git a/Mk/bsd.port.subdir.mk b/Mk/bsd.port.subdir.mk
index 7c33e35257aa..6f0a5b884839 100644
--- a/Mk/bsd.port.subdir.mk
+++ b/Mk/bsd.port.subdir.mk
@@ -406,12 +406,16 @@ _PORTSEARCH= \
fields["rdeps"] = 9; names[9] = "R-deps"; \
fields["www"] = 10; names[10] = "WWW"; \
split(display, d, /,[ \t]*/); \
- for (i in d) { \
- disp[fields[d[i]]] = 1; \
- } \
split(xdisplay, xd, /,[ \t]*/); \
- for (i in xd) { \
- delete disp[fields[xd[i]]]; \
+ for (i in d) { \
+ toprint = 1;\
+ for (j in xd) { \
+ if (d[i] == xd[j] ) { \
+ toprint=0; \
+ break;\
+ }\
+ } \
+ if (toprint == 1 ) disp[fields[d[i]]] = 1; \
} \
} \
{ \