aboutsummaryrefslogtreecommitdiffstats
path: root/Mk/bsd.port.subdir.mk
diff options
context:
space:
mode:
authorkrion <krion@FreeBSD.org>2006-01-22 01:37:14 +0800
committerkrion <krion@FreeBSD.org>2006-01-22 01:37:14 +0800
commit6377b27f77d3b8ca3ffd4867a57b4e7be32ab6ac (patch)
treedca11c502d0bd243534b867dc91d5cb34bdb1adb /Mk/bsd.port.subdir.mk
parent858c4e0ba24549dd475d1151d3982145bd8a83ff (diff)
downloadfreebsd-ports-gnome-6377b27f77d3b8ca3ffd4867a57b4e7be32ab6ac.tar.gz
freebsd-ports-gnome-6377b27f77d3b8ca3ffd4867a57b4e7be32ab6ac.tar.zst
freebsd-ports-gnome-6377b27f77d3b8ca3ffd4867a57b4e7be32ab6ac.zip
- Fix 'all-depends-list' target in cases if dependencies list is
very long and if some dependencies can't be added into the list. [1] - Fix FAM support. Make gamin the default FAM system. [2] - Introduce new 'quicksearch' target to show only port, path and info section of the matching ports. [3] - Introduce new category - rubygems. [4] - Fix stale dependencies while installing qmail slaveport and another port that depends on qmail. [5] - Add commentary for describes target in bsd.port.mk. [6] - Fix warning issued during make index on archs !368. [7] - Add USE_DOS2UNIX variable. If set to "YES", remove the ^M from all files under ${WRKSRC}. If set to a string, remove in all files under ${WRKSRC} with one of these names the ^Ms. [8] - Add new variables PERL_RUN_DEPENDS and PERL_BUILD_DEPENDS by checking the existance of the Perl modules with the "perl -e 'use module;'" command. [9] - Fix bsd.port.mk variable quoting issues. No quoting is necessary anymore either in the Makefile or on the command line. Affected variables include: BROKEN FORBIDDEN IGNORE MANUAL_PACKAGE_BUILD NO_CDROM NO_PACKAGE RESTRICTED [10] - Add NOFETCHFILES variable. If set, don't download these files from the ${MASTER_SITES} or ${MASTER_SITE_BACKUP} (but do from ${MASTER_SITE_OVERRIDE}). [11] - Improve 'search' target output. [12] - Add a new virtual category for Amateur Radio - hamradio. [13] - Cleanup some old/unused pathes in bsd.port.mk. [14] - Add @dirrmtry for plists which does the same as: "@unexec rmdir %D/foo 2>/dev/null || true" [15] - Remove virtual category - offix. [16] - Use portsnap instead of cvsup or cvs on "make update" in /usr/ports. [17] - Move location of bsd.autotools.mk within bsd.port.mk [18] - Add bsd.linux-rpm.mk, fix INSTALLS_SHLIB for Linux ports [19] - Use new USE_RC_SUBR format for FreeBSD version >= 700007 [20] - Replace the string "FreeBSD" by "The FreeBSD Project" in the security warning [21] - Add bsd.local.mk for local modification to ports framework. [22] - Replace rcNG spelling by rc.d [23] - Remove superfluous USE_REINPLACE. [24] Special thanks to: linimon for spending hours with all these patches clement for fixes kris for help with pointyhat PR: ports/86310 [1], ports/89498 [2], ports/83530 [3], ports/83789 [4], ports/84053 [5], ports/86281 [6], ports/87214 [7], ports/87234 [8], ports/87318 [9], ports/87396 [10], ports/87605 [11], ports/87840 [12], ports/88230 [13], ports/88493 [14], ports/88711 [15], ports/88751 [16], ports/89281 [17], ports/89999 [18], ports/90031 [19], ports/90150 [20], ports/90668 [21], ports/91433 [23], ports/88754 [24] Submitted by: mi [1], marcus [2], Lars Engels <lars.engels@0x20.net> [3], pav [4, 16, 20, 24], garga [5], cperciva [6], vd [7], edwin [8, 9, 11, 15, 21], fenner [10], Arseny Nasokin <tarc.po.cs.msu.su@tarc.po.cs.msu.su> [12], Carl Makin <carl@stagecraft.cx> [13], arved [14], NIIMI Satoshi <sa2c@sa2c.net> [17], thierry [18], jylefort [19], linimon [22], dougb [23]
Diffstat (limited to 'Mk/bsd.port.subdir.mk')
-rw-r--r--Mk/bsd.port.subdir.mk33
1 files changed, 23 insertions, 10 deletions
diff --git a/Mk/bsd.port.subdir.mk b/Mk/bsd.port.subdir.mk
index b3f988016f6a..7c33e35257aa 100644
--- a/Mk/bsd.port.subdir.mk
+++ b/Mk/bsd.port.subdir.mk
@@ -265,10 +265,8 @@ README= ${TEMPLATES}/README.category
.endif
COMMENTFILE?= ${.CURDIR}/pkg/COMMENT
DESCR?= ${.CURDIR}/pkg/DESCR
-.if ${OSVERSION} >= 600000
-INDEXFILE?= INDEX-6
-.elif ${OSVERSION} >= 500036
-INDEXFILE?= INDEX-5
+.if ${OSVERSION} >= 500036
+INDEXFILE?= INDEX-${OSVERSION:C/([0-9]).*/\1/}
.else
INDEXFILE?= INDEX
.endif
@@ -333,8 +331,11 @@ PORTSEARCH_KEYLIM?=0
PORTSEARCH_XKEYLIM?=0
PORTSEARCH_IGNORECASE?=1
-search: ${PORTSDIR}/${INDEXFILE}
- @here=${.CURDIR}; \
+_PORTSEARCH= \
+ here=${.CURDIR}; \
+ if [ ! -r ${PORTSDIR}/${INDEXFILE} ] ; then \
+ echo "The ${.TARGET} target requires ${INDEXFILE}. Please run make index or make fetchindex."; \
+ else \
cd ${PORTSDIR}; \
if [ -z "$$key" -a -z "$$xkey" -a \
-z "$$name" -a -z "$$xname" -a \
@@ -346,9 +347,9 @@ search: ${PORTSDIR}/${INDEXFILE}
-z "$$rdeps" -a -z "$$xrdeps" -a \
-z "$$www" -a -z "$$xwww" ]; \
then \
- echo "The search target requires a keyword parameter or name parameter,"; \
- echo "e.g.: \"make search key=somekeyword\""; \
- echo "or \"make search name=somekeyword\""; \
+ echo "The ${.TARGET} target requires a keyword parameter or name parameter,"; \
+ echo "e.g.: \"make ${.TARGET} key=somekeyword\""; \
+ echo "or \"make ${.TARGET} name=somekeyword\""; \
exit; \
fi; \
awk -F\| -v there="$$here/" -v top="$$(pwd -P)" \
@@ -365,6 +366,7 @@ search: ${PORTSDIR}/${INDEXFILE}
-v keylim="$${keylim:-${PORTSEARCH_KEYLIM}}" \
-v xkeylim="$${xkeylim:-${PORTSEARCH_XKEYLIM}}" \
-v display="$${display:-${PORTSEARCH_DISPLAY_FIELDS}}" \
+ -v xdisplay="$$xdisplay" \
'BEGIN { \
gsub(/\+/,"\\+",name); \
if (substr(there, 1, length(top)) == top) \
@@ -407,6 +409,10 @@ search: ${PORTSDIR}/${INDEXFILE}
for (i in d) { \
disp[fields[d[i]]] = 1; \
} \
+ split(xdisplay, xd, /,[ \t]*/); \
+ for (i in xd) { \
+ delete disp[fields[xd[i]]]; \
+ } \
} \
{ \
if (substr($$2, 1, therelen) != there) \
@@ -431,4 +437,11 @@ search: ${PORTSDIR}/${INDEXFILE}
if (i in disp) \
printf("%s:\t%s\n", names[i], $$i); \
print(""); \
- }' ${PORTSDIR}/${INDEXFILE}
+ }' ${PORTSDIR}/${INDEXFILE} ; fi
+
+search:
+ @${_PORTSEARCH}
+
+quicksearch:
+ @export display="name,path,info" ; \
+ ${_PORTSEARCH}