aboutsummaryrefslogtreecommitdiffstats
path: root/Mk/bsd.port.subdir.mk
diff options
context:
space:
mode:
authorasami <asami@FreeBSD.org>1996-04-01 19:13:00 +0800
committerasami <asami@FreeBSD.org>1996-04-01 19:13:00 +0800
commit748b4a063148b044eeedc30038f2841e35731a99 (patch)
tree09a5cc278618258977ae7381ea7ae088f127a890 /Mk/bsd.port.subdir.mk
parent47b293780e0b58bcd11ab91a923566e4a7bfa408 (diff)
downloadfreebsd-ports-gnome-748b4a063148b044eeedc30038f2841e35731a99.tar.gz
freebsd-ports-gnome-748b4a063148b044eeedc30038f2841e35731a99.tar.zst
freebsd-ports-gnome-748b4a063148b044eeedc30038f2841e35731a99.zip
Thanks for the overwhelming response (which can be only summarized by the
word: "zilch"). I guess the only way to get people try and comment on these kind of things is to shove it down their throat.... ;) Anyway, here's a set of changes required for auto-generation of READMEs in ports directories. Necessary changes and additions of templates to the ports tree will follow shortly. Eventually I'll commit all the generated READMEs to the tree, but that will be in the rather distant future. For now, I encourage anyone with a -current systam and a matching ports tree to do a "make readmes" at the top level and see what they get. Next step will be to add pkg/{COMMENT,DESCR} to all the categories.
Diffstat (limited to 'Mk/bsd.port.subdir.mk')
-rw-r--r--Mk/bsd.port.subdir.mk45
1 files changed, 44 insertions, 1 deletions
diff --git a/Mk/bsd.port.subdir.mk b/Mk/bsd.port.subdir.mk
index 416c332ec9d4..cc0868ce2db9 100644
--- a/Mk/bsd.port.subdir.mk
+++ b/Mk/bsd.port.subdir.mk
@@ -1,5 +1,5 @@
# from: @(#)bsd.subdir.mk 5.9 (Berkeley) 2/1/91
-# $Id: bsd.port.subdir.mk,v 1.11 1995/03/21 03:59:13 jkh Exp $
+# $Id: bsd.port.subdir.mk,v 1.12 1996/03/24 00:41:10 wosch Exp $
.MAIN: all
@@ -105,3 +105,46 @@ tags: _SUBDIRUSE
.if !target(checksum)
checksum: _SUBDIRUSE
.endif
+
+.if !target(readmes)
+readmes: readme _SUBDIRUSE
+.endif
+
+.if !target(readme)
+readme:
+ @rm -f README.html
+ @make README.html
+.endif
+
+PORTSDIR ?= /usr/ports
+TEMPLATES ?= ${PORTSDIR}/templates
+.if defined(PORTSTOP)
+README= ${TEMPLATES}/README.top
+.else
+README= ${TEMPLATES}/README.category
+.endif
+
+README.html:
+ @echo "===> Creating README.html"
+ @> $@.tmp
+.for entry in ${SUBDIR}
+.if defined(PORTSTOP)
+ @echo -n '<a href="'${entry}/README.html'">${entry}</a>: ' >> $@.tmp
+.else
+ @echo -n '<a href="'${entry}/README.html'">'"`cd ${entry}; make package-name`</a>: " >> $@.tmp
+.endif
+.if exists(${entry}/pkg/COMMENT)
+ @cat ${entry}/pkg/COMMENT >> $@.tmp
+.else
+ @echo "(no description)" >> $@.tmp
+.endif
+.endfor
+ @sort -t '>' +1 -2 $@.tmp > $@.tmp2
+ @cat ${README} | \
+ sed -e 's%%CATEGORY%%'`echo ${.CURDIR} | sed -e 's.*/\([^/]*\)$$\1'`'g' \
+ -e '/%%DESCR%%/r${.CURDIR}/pkg/DESCR' \
+ -e '/%%DESCR%%/d' \
+ -e '/%%SUBDIR%%/r$@.tmp2' \
+ -e '/%%SUBDIR%%/d' \
+ > $@
+ @rm -f $@.tmp $@.tmp2
sertions'>+8 * - convert USE_CMAKE to USESmakc2013-03-232-2/+2 * - Add New USES macro to handle support for Zenoss ports and Zenpacks:jgh2013-03-2011-68/+29 * Fix minor nit: use the canconical FreeBSD.org form for email addresses.eadler2013-03-181-2/+1 * In categories starting with [n-s], remove empty lines (and also few cases ofdanfe2013-03-172-2/+0 * Remove expired ports:rene2013-03-1516-954/+0 * Do not removed directories not owned by the portbapt2013-03-132-8/+1 * - Update to 5.2.1beech2013-03-138-243/+241 * Update to 1.2 [1]zeising2013-03-123-26/+531 * Clean up my ports (and a couple of ports@ owned ones):eadler2013-03-091-0/+2 * Remove indefinite article from COMMENTehaupt2013-03-081-6/+2 * Convert USE_BISON to USES= bisonbapt2013-03-086-21/+9 * * Update the glib to 2.34.3 and gtk20 to 2.24.17 and gtk30 to 3.6.4 whichkwm2013-03-082-0/+2 * - Convert to OptionsNGmiwi2013-03-081-21/+16 * Convert to new options frameworkbapt2013-03-071-19/+18 * - replace deprecated devel/py-setuptools with devel/py-distributerm2013-03-051-2/+2 * 2013-02-27 security/lep: No more upstream, no more public distfilesbapt2013-03-049-282/+0 * update to nagiosql 3.2.0_SP2ohauer2013-03-0414-285/+96 * Update to 2.2.1crees2013-03-032-4/+3 * Devmon is a Perl daemon designed to supplement and enhance the monitoringswills2013-03-03