aboutsummaryrefslogtreecommitdiffstats
path: root/Mk/bsd.port.subdir.mk
diff options
context:
space:
mode:
authorasami <asami@FreeBSD.org>1996-11-01 15:22:37 +0800
committerasami <asami@FreeBSD.org>1996-11-01 15:22:37 +0800
commitcb245860281d30627ca31c9b548b80a1ffaec167 (patch)
tree411df31d888de5dee84e6b16b6af0ca1b5b11823 /Mk/bsd.port.subdir.mk
parent74476a08fabe38ee98009b8c4ca58bd00af8fb74 (diff)
downloadfreebsd-ports-gnome-cb245860281d30627ca31c9b548b80a1ffaec167.tar.gz
freebsd-ports-gnome-cb245860281d30627ca31c9b548b80a1ffaec167.tar.zst
freebsd-ports-gnome-cb245860281d30627ca31c9b548b80a1ffaec167.zip
(1) Add NetBSD support. Closes PR bin/1643.
Submitted by: Jason Thorpe <thorpej@nas.nasa.gov> (2) Remove the bogus "CAT+=" definition. Closes PR ports/1703. Submitted by: Peter Childs <pjchilds@imforei.apana.org.au> (3) Change MKDIR to "/bin/mkdir -p", remove "-p" from ${MKDIR} invocations. Closes PR ports/1901. Submitted by: obrien (4) Add a new macro variable COMPRESS_MAN, which will evaluate to gzip if NOMANCOMPRESS isn't set (default), or true if it is. (5) Add a new variable NO_CHECKSUM, which will disable the md5 checksum. Submitted by: jkh (6) Also, move NO_PATCH and NO_PACKAGE checks to right place in invocation order. (7) Check for LIB_DEPENDS before installation too. (It used to check only before extraction.) Forgotten a long time ago by: asami
Diffstat (limited to 'Mk/bsd.port.subdir.mk')
-rw-r--r--Mk/bsd.port.subdir.mk9
1 files changed, 8 insertions, 1 deletions
diff --git a/Mk/bsd.port.subdir.mk b/Mk/bsd.port.subdir.mk
index b4e28e8823b2..88187fde8ac3 100644
--- a/Mk/bsd.port.subdir.mk
+++ b/Mk/bsd.port.subdir.mk
@@ -1,5 +1,5 @@
# from: @(#)bsd.subdir.mk 5.9 (Berkeley) 2/1/91
-# $Id: bsd.port.subdir.mk,v 1.13 1996/04/01 11:13:00 asami Exp $
+# $Id: bsd.port.subdir.mk,v 1.14 1996/04/09 22:54:13 wosch Exp $
.MAIN: all
@@ -7,6 +7,9 @@
STRIP?= -s
.endif
+.if !defined(OPSYS) # XXX !!
+OPSYS!= uname -s
+.endif
ECHO_MSG?= echo
@@ -71,7 +74,11 @@ readme:
@make README.html
.endif
+.if (${OPSYS} == "NetBSD")
+PORTSDIR ?= /usr/opt
+.else
PORTSDIR ?= /usr/ports
+.endif
TEMPLATES ?= ${PORTSDIR}/templates
.if defined(PORTSTOP)
README= ${TEMPLATES}/README.top