aboutsummaryrefslogtreecommitdiffstats
path: root/Mk/bsd.port.subdir.mk
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2004-01-20 17:14:10 +0800
committermarcus <marcus@FreeBSD.org>2004-01-20 17:14:10 +0800
commit9b747a6546b43692ef04ef91fe2d40b9d13ddcde (patch)
treea35e44fad8dbd6348f9b55672e3be34d62267529 /Mk/bsd.port.subdir.mk
parent7d8cb0c07b6cf936343a244b6330c2442937d54f (diff)
downloadfreebsd-ports-gnome-9b747a6546b43692ef04ef91fe2d40b9d13ddcde.tar.gz
freebsd-ports-gnome-9b747a6546b43692ef04ef91fe2d40b9d13ddcde.tar.zst
freebsd-ports-gnome-9b747a6546b43692ef04ef91fe2d40b9d13ddcde.zip
Here come the patches!
* Add ghostscript knobs [1] * Add per-port persistent build options with a menu-driven front-end [2] * Allow porters to override the message generated when do-configure fails [3] * Add patch to obviate many pkg-plist files [4] * Fix the PKG_DBDIR comment [5] * Make ports framework more robust with regard to make index [6] * Add new command macros to bsd.port.mk [7] * Remove direct command use from bsd.port.mk [8] * Make the ports system respect WITHOUT_CPU_CFLAGS [9] * Break the SDL code out into bsd.sdl.mk [10] * Add working support for USE_SIZE [11] * Fix RANDOMIZE_MASTER_SITES on -CURRENT [12] * Convert some spaces to tabs [13] * Add new physcial categories accessibility and x11-themes [14] * Speed up GNU configure scripts [15] * Remove "//" from MLINKS items in PLISTs and fix make -s install and make -s deinstall [16] * Be more specific about looking for files in distinfo [17] * Add new run-autotools target, and resort configure targets [18] * Make CONFLICTS compare prefix for installed packages and PREFIX [19] * Change directory to ${.CURDIR} before running certain make commands [20] * When INSTALL_AS_USER is set, run ldconfig with failures ignored [21] * Speed up the security check phase [22] * Fix some corner cases in the PORTDOCS code [23] * Add a new DEPRECATED macro [24] * Make INDEX breakage more informative [25] Look for a full write-up to follow on ports@ and ports-developers@. PR: 36112 [1] 59909 [4] 61351 [6] 59058 [7] 59058 [8] 59493 [9] 55494 [10] 59058 [11] 59315 [12] 59058 [13] 59811 [15] 59058 [16] 59058 [17] 60882 [18] 58149 [19] 59058 [20] 61133 [21] 55331 [22] 59070 [23] 59362 [24] 59626 [25] Submitted by: linimon [1] eivind [2] marcus [3] trevor [4] gerald [5] linimon [6] eik [7] eik [8] jeh [9] edwin [10] eik [11] Sergey Matveychuk <sem@ciam.ru> [12] eik [13] trevor gnome [14] adamw [15] eik [16] eik [17] edwin [18] clement [19] eik [20] edwin lev [21] Eugene M. Kim <ab@astralblue.com> [22] eik [23] linimon [24] eik [25]
Diffstat (limited to 'Mk/bsd.port.subdir.mk')
-rw-r--r--Mk/bsd.port.subdir.mk40
1 files changed, 38 insertions, 2 deletions
diff --git a/Mk/bsd.port.subdir.mk b/Mk/bsd.port.subdir.mk
index 6164c6f3b5c0..94444778c2bb 100644
--- a/Mk/bsd.port.subdir.mk
+++ b/Mk/bsd.port.subdir.mk
@@ -83,7 +83,6 @@ TARGETS+= configure
TARGETS+= deinstall
TARGETS+= depend
TARGETS+= depends
-TARGETS+= describe
TARGETS+= distclean
TARGETS+= extract
TARGETS+= fetch
@@ -108,7 +107,7 @@ ${__target}:
.if defined(SUBDIR) && !empty(SUBDIR)
-.for __target in ${TARGETS} checksubdirs readmes
+.for __target in ${TARGETS} checksubdirs describe readmes
${SUBDIR:S/^/_/:S/$/.${__target}/}: _SUBDIRUSE
.endfor
@@ -186,6 +185,43 @@ checksubdir:
done
.endif
+.if !target(describe)
+.if defined(PORTSTOP)
+describe: ${SUBDIR:S/^/_/:S/$/.describe/}
+.else
+describe:
+ @TMPFILE=`mktemp -q /tmp/describe.XXXXXX` || exit 1; \
+ for sub in ${SUBDIR}; do \
+ OK=""; \
+ for dud in $$DUDS; do \
+ if [ $${dud} = $$sub ]; then \
+ OK="false"; \
+ ${ECHO_MSG} "===> ${DIRPRFX}$$sub skipped"; \
+ fi; \
+ done; \
+ if test -d ${.CURDIR}/$${sub}.${MACHINE_ARCH}; then \
+ edir=$${sub}.${MACHINE_ARCH}; \
+ elif test -d ${.CURDIR}/$${sub}; then \
+ edir=$${sub}; \
+ else \
+ OK="false"; \
+ ${ECHO_MSG} "===> ${DIRPRFX}$${sub} non-existent"; \
+ fi; \
+ if [ "$$OK" = "" ]; then \
+ ${ECHO_MSG} "===> ${DIRPRFX}$${edir}"; \
+ cd ${.CURDIR}/$${edir}; \
+ ${MAKE} -B describe 2>$${TMPFILE}; \
+ if [ -s $${TMPFILE} ]; then \
+ echo "===> ${DIRPRFX}$${sub} failed:" >&2; \
+ cat $${TMPFILE} >&2; \
+ echo -n >$${TMPFILE}; \
+ fi; \
+ fi; \
+ done; \
+ rm -f $${TMPFILE}
+.endif
+.endif
+
.if !target(readmes)
readmes: readme ${SUBDIR:S/^/_/:S/$/.readmes/}
.endif