aboutsummaryrefslogtreecommitdiffstats
path: root/Mk/bsd.python.mk
diff options
context:
space:
mode:
authorlwhsu <lwhsu@FreeBSD.org>2012-12-24 01:52:46 +0800
committerlwhsu <lwhsu@FreeBSD.org>2012-12-24 01:52:46 +0800
commit159b6f81ef3041b1f3ac02317185100f0155986b (patch)
tree7b7863a91726bf0c0cdaa1808b76f78087314103 /Mk/bsd.python.mk
parent0941203f470bc1cb0633aa70f65b53561df81f82 (diff)
downloadfreebsd-ports-gnome-159b6f81ef3041b1f3ac02317185100f0155986b.tar.gz
freebsd-ports-gnome-159b6f81ef3041b1f3ac02317185100f0155986b.tar.zst
freebsd-ports-gnome-159b6f81ef3041b1f3ac02317185100f0155986b.zip
- Remove "first-installed-win" logic for automatically setting
${PYTHON_DEFAULT_VERSION}, this generates conflicting packages. - Create symbolic links as PEP 394 [1] suggests. ${PYTHON_DEFAULT_VERSION} will create python and python${MAJOR_VERSION} links. In current default, lang/python27 will create: python -> python2 -> python2.7 - Introduce ${PYTHON3_DEFAULT_VERSION}, which will handle bin/python3 link. At this point, lang/python33 will create python3 -> python3.3 - Minor cleanups * Trim Makefile headers * Remove ${OSVERSION} detection for xz, whihc is done by USE_XZ [1] http://www.python.org/dev/peps/pep-0394/
Diffstat (limited to 'Mk/bsd.python.mk')
-rw-r--r--Mk/bsd.python.mk12
1 files changed, 12 insertions, 0 deletions
diff --git a/Mk/bsd.python.mk b/Mk/bsd.python.mk
index c75e4b04f0b7..f8951fc90f45 100644
--- a/Mk/bsd.python.mk
+++ b/Mk/bsd.python.mk
@@ -87,6 +87,12 @@ Python_Include_MAINTAINER= python@FreeBSD.org
# in case you want to use an older version as a default.
# default: python2.7
#
+# PYTHON3_DEFAULT_VERSION
+# - Version of the default python binary in your ${PATH}, in
+# the format "python3.2". Set this in your /etc/make.conf
+# in case you want to use an older version as a default.
+# default: python3.3
+#
# PYTHON_MAJOR_VER - Python version major number. 2 for python-2.x,
# 3 for python-3.x and so on.
#
@@ -274,6 +280,12 @@ _PYTHON_DEFAULT_VERSION= ${_PYTHON_PORTBRANCH}
PYTHON_DEFAULT_VERSION= python${_PYTHON_DEFAULT_VERSION}
.endif
+.if ${PYTHON_DEFAULT_VERSION:R} == "python3"
+PYTHON3_DEFAULT_VERSION= ${PYTHON_DEFAULT_VERSION}
+.else
+PYTHON3_DEFAULT_VERSION= python3.3
+.endif
+
.if defined(PYTHON_VERSION)
_PYTHON_VERSION:= ${PYTHON_VERSION:S/^python//}
_PYTHON_CMD= ${LOCALBASE}/bin/${PYTHON_VERSION}